Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2006
    Posts
    14

    Unanswered: ORA-12154: TNS:could not resolve the connect identifier specified

    Hi,

    I created a seperate oracle 10.1 database for our application successfully on Fedora Linux OS Hat.
    Currently, I access to remote database server through putty SSH.
    I can connect also our database successfully but when I tried it to connect through service name it gives
    me the following error message.


    ERROR:
    ORA-12154: TNS:could not resolve the connect identifier specified

    When I tried to check it from the OS prompt as below, it gives me this error message

    tnsping db1

    TNS Ping Utility for Linux: Version 10.1.0.2.0 - Production on 11-OCT-2006 15:09:46

    Copyright (c) 1997, 2003, Oracle. All rights reserved.

    Used parameter files:
    /u01/app/oracle/product/10.1.0/db_1/network/admin/sqlnet.ora

    TNS-03505: Failed to resolve name


    I have defined the following in the concern network file

    SQlnet.ora

    NAMES.DIRECTORY_PATH= (TNSNAMES,EZCONNECT)

    Tnsnames.ora

    DB1.POLO=
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP) (HOST = 117.159.154.15) (PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = DB1.polo)

    I've specified the follwing concern parameters in the initDB1.ora file as below:


    db_domain=polo
    db_name=DB1
    instance_name=DB1

    Do I need to define the value of the parameter db_unique_name?


    Do I need to create a service name using oradim or something else is wrong to connect successfully through
    service name or connect descriptor?



    Thanks in advance.

    Jay

  2. #2
    Join Date
    Mar 2004
    Posts
    370
    You should tell it that your tnsnames is DB1.POLO:
    SQL> conn scott/tiger@DB1.POLO
    sould work for you.

  3. #3
    Join Date
    Oct 2006
    Posts
    14

    not working

    unfortunately, it is not working. Any more ideas.

    Thanks

    jayesh

  4. #4
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    The SQLNET.ora file may need to have a default domain specified. Not sure of the syntax, so I will leave that up to the interested reader.

  5. #5
    Join Date
    Oct 2006
    Posts
    14
    Yes, it is at the default domain.

  6. #6
    Join Date
    Sep 2004
    Posts
    60
    1. Please check if your alias name in TNS entry have any space.
    If yes remove it.

    2. Rename sqlnet.ora to sqlnet_old.ora and try connecting again.

  7. #7
    Join Date
    Oct 2006
    Posts
    1
    In SQLNET.ORA file, check for the correct name or any unwanted space for TNSNAMES in the NAMES.DIRECTORY_PATH parameter.

    If it doesnot work rename the SQLNET.ORA and try using the tnsping command, so that it will refer the TNSNAMES.ORA file.

    RTGPERF,
    http://groups.google.co.in/group/database-tuning

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •