Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2006
    Posts
    13

    Unanswered: Backspace dosen't work properly for isql on Linux

    I found backspace dosen't work properly for isql on my linux machine,
    ^? appear when I press backspress,
    Any setting should be changed ? thanks

    linux01 /home/sybase> isql -SDETDB04 -Usa
    Password:
    1> select * from TD^?^?^?^?

    P.S. Backspace works properly for shell on my machine.

  2. #2
    Join Date
    Jan 2003
    Location
    Geneva, Switzerland
    Posts
    353
    Before starting isql run this in the shell:

    stty erase <backspace>

    where <backspace> is ^? (i.e. hit the backspace key).

    Michael

  3. #3
    Join Date
    Oct 2006
    Location
    amara no meikyuu
    Posts
    15
    this is not a problem with isql, its a problem with the linux terminal. you can also add the stty in the .profile or init scripts. to get a list of the settings type 'stty -a'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •