Results 1 to 3 of 3
  1. #1
    Join Date
    May 2004

    Question Unanswered: MSDTC Error - Urgent

    Hi all

    I got the error below after run the query:

    INSERT TABLE1 -- ran at SERVER1
    EXEC [SERVER2].DB2.dbo.spInformation
    @VR_STARTSHIFT = '10/10/2006 06:00:00',
    @VR_INCDATE = '10/10/2006 14:00:00',
    @VR_STATION_ID = 221

    Server: Msg 7391, Level 16, State 1, Line 1
    The operation could not be performed because the OLE DB provider 'SQLOLEDB' was unable to begin a distributed transaction.
    [OLE/DB provider returned message: New transaction cannot enlist in the specified transaction coordinator. ]
    OLE DB error trace [OLE/DB Provider 'SQLOLEDB' ITransactionJoin::JoinTransaction returned 0x8004d00a].

    Server1 has a linked server to Server2 (this linked server is working because i can run the SP without the insert).
    The Server1 is under WIN2K Server and Sever2 is under WIN2003
    The MSDTC is installed and is running in both servers.

    How can I fix that?

    Thanks in advance
    Manuel Rodrigues

  2. #2
    Join Date
    Feb 2004
    In front of the computer
    Provided Answers: 54
    Run down the list, paying special attention to ensure that MSDTC.EXE has an exception in the Windows Firewall.


  3. #3
    Join Date
    May 2004
    [Edit: on second reading of you error msg, I realize now our error was different. so this probably isn't the fix for you.]

    We saw this too. In our environment this fixed it:

    Log into the machine named in the error message via termserv.
    Start, Run, type 'dcomcnfg.exe' This brings up the security manager.

    Click Component Services/Computers/My Computer folder

    Right click My Computer and select properties.

    Pick the MSDTC tab.

    Click the Security Configuration Button

    Click Network DTC Access checkbox.

    Click 'Allow Inbound', 'Allow Outbound' checkboxes.
    Last edited by jezemine; 10-20-06 at 13:37.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts