Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2006

    Unanswered: SQL22205C The DB2 Administration Server Error

    I am using DB2 "DB2 v8.1.7.445 s040812", "WR21342", and FixPak "7".
    Product Name = "DB2 Universal Database Express Edition"
    Product Identifier = "DB2EXP"
    Version Information = "8.2"
    My O/S is Windows XP.

    After I installed DB2, when I try to create a database through control centre, the following errors are displaying.

    SQL22205C The DB2 Administration Server encountered an
    unexpected error while executing a request.


    An unexpected error occurred in the DB2 Administration Server
    while it was processing a request.

    User Response:

    Refer to the DB2 Administration Server's First Failure Data
    Capture Log for additional information.

    If trace was active, invoke the Independent Trace Facility at
    the operating system command prompt. Contact IBM Support with
    the following required information:

    o Problem description

    o SQLCODE or message number

    o SQLCA contents if possible

    o Trace file if possible

    Instance name=DB2DAS00
    This error is not occured earlier when I first installed and created database.
    My PC's 'C' drive has been formatted where Operating system resides without uninstalling the existed DB2 database software. After Formatting, I deleted the previously DB2 installed directories.Then I installed DB2 database software.Now the error is raising while creating new database through control centre.

  2. #2
    Join Date
    Jul 2004
    I have still the same problem. It seems that it happens when one works with a restored database (i.e. previous DB2 version, or from another machine), in a new environment. Maybe there is a extra step/task that we need to perform.
    Tell me if u have any news.

  3. #3
    Join Date
    Jul 2004
    Hi Kswaughs:

    This is how I solved the problem:
    You need the user/password used to login into your Server where DB2 resides (I mean Windows User). Let's say they are: us1 and pw1.

    In Command Window (DB2 CLP):
    1) db2admin stop
    2) db2admin drop
    3) db2admin create /user:us1 /passwordw1
    4) db2admin start
    That's all.

    Let me know if it worked for you...
    Hope this helps.

  4. #4
    Join Date
    Aug 2007
    Thanks a lot francis01.

    Ihad the same problem of kswaughs, but triying your solution was solved successfully.

  5. #5
    Join Date
    Jan 2012
    Hi francis01,

    I had the same problem and it was resolved with the given steps.

    Thanks francis01.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts