Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2006
    Posts
    5

    Unanswered: Index are not coming in Query Explain diagram of Query

    Hi

    I have applied Index I1 on Table T1 which has about 50 K rows.But when i say explain SQL from Control Center i am not seeing any of indexes (Ie IXSCAN Hexagon ) in Access path diagram.Is there any setting to view indexes on table in explain query.I have run RUNSTAT command also on Table T1

    Thanks in Advaance

  2. #2
    Join Date
    Jan 2003
    Posts
    1,605
    Hi,
    if there is an index on table, there is not 100% DB2 will use it. You should create indexes on "where conditions".

    Can you post the table description (db2 describe table table_name) and index syntax (db2 create index ...).

    Hope this helps,
    Grofaty

  3. #3
    Join Date
    Nov 2006
    Posts
    5
    Column Type Type
    name schema name Length Scale Nulls

    ------------------------------ --------- ------------------ -------- ----- -----
    -
    TABSCHEMA SYSIBM VARCHAR 128 0 No

    TABNAME SYSIBM VARCHAR 128 0 No

    COLNAME SYSIBM VARCHAR 128 0 No

    COLNO SYSIBM SMALLINT 2 0 No

    TYPESCHEMA SYSIBM VARCHAR 128 0 No

    TYPENAME SYSIBM VARCHAR 128 0 No

    LENGTH SYSIBM INTEGER 4 0 No

    SCALE SYSIBM SMALLINT 2 0 No

    NULLS SYSIBM CHARACTER 1 0 No

    IDENTITY SYSIBM CHARACTER 1 0 No

    REMARKS SYSIBM VARCHAR 254 0 Yes



    CREATE INDEX IND_T_COLUMNS ON T_DB2_COLUMNS (TABSCHEMA ASC,TABNAME ASC,COLNAME ASC,COLNO ASC)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •