Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2006
    Posts
    9

    Unanswered: problem with triggers

    hi.

    In my form i need to validate two text fields. the validation process includes null checking and special character checking..and i used key-next-item trigger to validate the text field n it is working..when i press tab key the validation is working but when i use mouse to navigate the text fields the validation is not working...any suggestion..


    thanx in advance...

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Use appropriate trigger. KEY-NEXT-ITEM is not appropriate. WHEN-VALIDATE-ITEM is.

  3. #3
    Join Date
    Oct 2006
    Posts
    9
    but in my form i need to navigate to next item if the validation is success....but when-validate-item doesn't support go_item.....any suggestion

  4. #4
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    If validation is successful, you'll easily navigate to the next item. Just press TAB, Enter or click with the mouse - do not use GO_ITEM (but you've already seen that - it is a restricted procedure and can not be used in WVI trigger). If it is not successful, raise an error and you'll stay in current item.

    Once again: item validation is to be done in the WHEN-VALIDATE-ITEM trigger.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •