Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2006
    Posts
    2

    Unanswered: Database not found after adding new database

    There are 12 Databases on one instance, I have created a new database in the same instance. after the creation, I am unable to access the old 12 Databases existing prior to the creation of new database. I observed that the Instance Home directory is full, so I have trimmed the diaglog.


    I see the following messages in Diag log:


    2006-12-07-17.58.24.554321+000 E3141972541C324 LEVEL: Error (OS)
    PID : 422106 TID : 1 PROC : db2pfchr 0
    INSTANCE: lddd012 NODE : 000
    FUNCTION: DB2 UDB, oper system services, sqloCSemP, probe:1
    CALLED : OS, -, unspecified_system_function
    OSERR : EINVAL (22) "Invalid argument"

    2006-12-07-17.58.24.554477+000 E3141972866C324 LEVEL: Error (OS)
    PID : 422106 TID : 1 PROC : db2pfchr 0
    INSTANCE: lddd012 NODE : 000
    FUNCTION: DB2 UDB, oper system services, sqloCSemP, probe:1
    CALLED : OS, -, unspecified_system_function
    OSERR : EINVAL (22) "Invalid argument"

    2006-12-07-17.58.24.554633+000 E3141973191C324 LEVEL: Error (OS)
    PID : 422106 TID : 1 PROC : db2pfchr 0
    INSTANCE: lddd012 NODE : 000
    FUNCTION: DB2 UDB, oper system services, sqloCSemP, probe:1
    CALLED : OS, -, unspecified_system_function
    OSERR : EINVAL (22) "Invalid argument"

    2006-12-07-22.38.34.810966+000 E3142054641C396 LEVEL: Error (OS)
    PID : 307400 TID : 1 PROC : db2agent (instance) 0
    INSTANCE: lddd012 NODE : 000
    APPHDL : 0-10 APPID: *LOCAL.lddd012.061207223834
    FUNCTION: DB2 UDB, oper system services, sqloexec2, probe:2
    CALLED : OS, -, unspecified_system_function
    OSERR : EEXIST (17) "File exists"

    2006-12-07-22.38.34.814041+000 E3142055038C398 LEVEL: Error (OS)
    PID : 307400 TID : 1 PROC : db2agent (instance) 0
    INSTANCE: lddd012 NODE : 000
    APPHDL : 0-10 APPID: *LOCAL.lddd012.061207223834
    FUNCTION: DB2 UDB, oper system services, sqloexec2, probe:2
    CALLED : OS, -, unspecified_system_function
    OSERR : EBADF (9) "Bad file number"

    ---------------------------------------
    When I tried to connect/drop/backup/restore, I am getting the following error:
    SQL1013N The database alias name or database name "LDMU411S" could not be
    found. SQLSTATE=42705

    But I am able to list the Database when I do a
    Db2 list db directory.

    Can some one please help me on this issue.

  2. #2
    Join Date
    Jun 2001
    Posts
    20
    Can you send the output of "db2 list db directory"?
    Renga

  3. #3
    Join Date
    Jun 2006
    Posts
    471

    db

    try
    db2 list db directory on /home/xxx
    wherever the database have been created before
    then
    db2 catalog db xx on /home/xxx
    this should bring back the db
    Best Regards, Guy Przytula
    DB2 UDB LUW certified V6/7/8

  4. #4
    Join Date
    Dec 2006
    Posts
    2
    when i try to do a catalog db xxx it says the db is not found.
    its showing me when i list the db directory.

  5. #5
    Join Date
    Jun 2006
    Posts
    471

    db

    can you copy part of list db directory on /xxx
    and the message from catalog db on /xxx
    Best Regards, Guy Przytula
    DB2 UDB LUW certified V6/7/8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •