Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2006
    Posts
    2

    Arrow Unanswered: Hello everybody !!! - Problem with db2cc #connection to ":0.0" refused by server#

    I'm rooot
    I'm using db2 v9.1 on Redhat AS 4
    when i try start DB2 Control Center :
    #
    [db2inst1@localhost adm]$ db2cc
    #

    ---->

    #
    [1] 14398
    [db2inst1@localhost adm]$ Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Exception in thread "main" java.lang.NoClassDefFoundError: sun.awt.X11.XToolkit
    at java.lang.J9VMInternals.initialize(J9VMInternals.j ava:127)
    at java.lang.Class.forNameImpl(Native Method)
    at java.lang.Class.forName(Class.java:131)
    at java.awt.Toolkit$2.run(Toolkit.java:864)
    at java.security.AccessController.doPrivileged(Access Controller.java:191)
    at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:84 7)
    at javax.swing.UIManager.initialize(UIManager.java:12 96)
    at javax.swing.UIManager.maybeInitialize(UIManager.ja va:1279)
    at javax.swing.UIManager.getDefaults(UIManager.java:5 90)
    at javax.swing.UIManager.get(UIManager.java:852)
    at com.ibm.db2.tools.common.CommonUIManager.initializ e(Unknown Source)
    at CC.setLookAndFeel(Unknown Source)
    at CC.<init>(Unknown Source)
    at CC.main(Unknown Source)
    DB2JAVIT : RC = 1


    #

    Please help me ? Thank !!!

  2. #2
    Join Date
    Dec 2006
    Posts
    2

    Arrow Hello everybody !!! - Problem with db2cc

    I'm rooot
    I'm using db2 v9.1 on Redhat AS 4
    when i try start DB2 Control Center :
    #
    [db2inst1@localhost adm]$ db2cc
    #
    ---->
    #
    [1] 14398
    [db2inst1@localhost adm]$ Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Exception in thread "main" java.lang.NoClassDefFoundError: sun.awt.X11.XToolkit
    at java.lang.J9VMInternals.initialize(J9VMInternals.j ava:127)
    at java.lang.Class.forNameImpl(Native Method)
    at java.lang.Class.forName(Class.java:131)
    at java.awt.Toolkit$2.run(Toolkit.java:864)
    at java.security.AccessController.doPrivileged(Access Controller.java:191)
    at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:84 7)
    at javax.swing.UIManager.initialize(UIManager.java:12 96)
    at javax.swing.UIManager.maybeInitialize(UIManager.ja va:1279)
    at javax.swing.UIManager.getDefaults(UIManager.java:5 90)
    at javax.swing.UIManager.get(UIManager.java:852)
    at com.ibm.db2.tools.common.CommonUIManager.initializ e(Unknown Source)
    at CC.setLookAndFeel(Unknown Source)
    at CC.<init>(Unknown Source)
    at CC.main(Unknown Source)
    DB2JAVIT : RC = 1


    #

    Please help me ? Thank !!!

  3. #3
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Your problem is that you do not have X privaleges.
    Do set the privalege, as root, type "xhost +"

    HTH

    Andy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •