Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2004
    Posts
    74

    Unanswered: "Table xxx not exists" error

    good day to all,

    when i copy a folder belong to one database from data folder, then i copy it to another pc , when i query it , it give me error like "table xxx not exist" , how to solve it

    it is both same version in 5.0,

    thank you

  2. #2
    Join Date
    Dec 2005
    Location
    Tilburg, Netherlands
    Posts
    73
    I think this trick will only work with MyIsam tables. Please be more specific about the tables and we might be able to help ...

    Gr,
    Yveau

    > SELECT * FROM users WHERE clue > 0;
    Empty set (0.00 sec)


  3. #3
    Join Date
    Mar 2004
    Posts
    74
    how to check table type ?

  4. #4
    Join Date
    Dec 2005
    Location
    Tilburg, Netherlands
    Posts
    73
    This one will do the trick:

    Code:
    SELECT TABLE_NAME, ENGINE from INFORMATION_SCHEMA.TABLES

    Gr,
    Yveau

    > SELECT * FROM users WHERE clue > 0;
    Empty set (0.00 sec)


  5. #5
    Join Date
    Mar 2004
    Posts
    74
    hi all,

    when i run the query,

    i get the engine type for my new added table equal to "null" and others in "myISAM"

  6. #6
    Join Date
    Dec 2005
    Location
    Tilburg, Netherlands
    Posts
    73
    So the one you're looking for is MyIsam ? Or is
    ... my new add table
    the one you're looking for ?

    Just in case, what OS are you on ? In some cases (like in my Debian Linux installation) table names are Case Sensitive ...

    Gr,
    Yveau

    > SELECT * FROM users WHERE clue > 0;
    Empty set (0.00 sec)


  7. #7
    Join Date
    Mar 2004
    Posts
    74
    yes , it is MyIsam and i use it in window

    can i set all tables to myIsam type ? how i do that, any idea on this ?

    thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •