Results 1 to 3 of 3

Thread: Exporting error

  1. #1
    Join Date
    Dec 2006
    Location
    Florida
    Posts
    4

    Unanswered: Exporting error

    I have an error that has me pulling my hair out. I have a database that I am trying to export a table from into another MS Access database. The database I am exporting to already has a copy of said table. During the export process, the dialog box appears informing me that the database object already exists and do I want to replace it with the copy I am exporting. I click 'yes' and after about half way on the progress bar another dialog box appears, this Invalid Error. Selecting help for further information, it is a Invalid argument error 3001:

    You tried to perform an operation that involves a routine in a DLL, and one of the arguments to the routine is invalid. Check your entry to make sure you have specified the correct arguments, and then try the operation again.

    This error also occurs when you attempt to use mutually exclusive constants in an argument to a method, such as specifying both dbConsistent and dbInconsistent in the options argument to the OpenRecordset method.


    By going to the target database and performing a compact and repair operation, I am able to then go back and export the table into the database, otherwise it is the same error every time. This is something that has happened as of recent and I am not sure what triggered the event. The target database is 1.36GB with the table in question loaded and 543mb without said table. Should I just suck it up and delete the table, compact and repair each time prior to the export or does anyone have an idea what the fix may be?

    Thanks for the help.

  2. #2
    Join Date
    Dec 2006
    Posts
    53
    Why not just link the table in the destination database to the table in the source database? It seems like there must be an easier way of accomplishing whatever you're trying to do that has you exporting from an Access database to an Access database.

  3. #3
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926
    My guess is that it's possibly a data problem. I'm guessing you may have a field which somehow it can't interpret correctly. I suppose there's now way to find exactly where but can you export out a smaller file (say the first few records)? Do you get the same error when exporting out 2-3 records? dfwelch is on to something where you could link the table in and just run a few queries.
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •