Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2005
    Posts
    113

    Unanswered: Sub reports problem

    I have a report, rptReportMain, with two sub reports, subAdress and subVehicle.

    The user can choose if he wants to view both adresses and vehicle or only one of those. I use subAdress.visable = False in the detail formating event.

    I'd like to also be able to view when information about adress is missing, but I don' know how to. I've tried all events in the subAdress to change the subAdress label to lbl.caption = "Missing". But when information in subAdress is missing, no events are started.

  2. #2
    Join Date
    Mar 2004
    Location
    Hong Kong
    Posts
    29
    I also encounter the same problem, I am working on a database which stores the extra-curricular activities of students. I have to create a report which contains two sub-reports
    1) The clubs and positions of the student
    2) Activities details of that student has joined

    If for some students who haven't joined any club, so sub-report part 1) will not appear, but I want to indicate that the student hasn't joined any club by displaying a "NIL" label for that part. How can I achieve this?

    Thanx in advance

  3. #3
    Join Date
    Nov 2005
    Posts
    113
    I've solved ut like this, now:

    I wrote rptMain report in event Detali_Print

    'CurrentRecord is 0 when rpt is empty

    If Report_rptAdress.CurrentRecord = 0 Then
    lblAdress.Caption = "Adress is missing"
    end if

    Hope that this helps you too. Happy new year!

  4. #4
    Join Date
    Mar 2004
    Location
    Hong Kong
    Posts
    29

    Sub report problem

    Hi

    It works perfectly well now. Thanks very much. Happy New Year Too!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •