Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2006

    Unanswered: Cannot get a good dump.

    For about the past week - 2 weeks I have tried to get a good dump of one of our databases.
    We run Sybase 12.5 on Linux.
    i have run dbcc checkalloc(db_name)
    sometimes it says i have corruption sometimes it does not
    so i kick all our users off
    put it in singel user mode
    dbcc checkalloc(db_name,fix)
    put back in multi
    still the same error
    it gets to the same part every time
    and bombs out
    below is a sample of my error.

    Server 'Server name', Procedure 'bs_begin_phase', Line 0:
    Backup Server: Database dbname: 2092522 kilobytes DUMPed.
    Server Message: Number 414502, Severity 2
    Server 'Server name', Procedure 'bs_begin_phase', Line 0:
    Backup Server: [3] Error for device 'dump location/dump name'. Error writing to archive device 'dump location/dump name'. Attempted to write 65536 bytes, 8191 bytes were written.
    Server Message: Number 500702, Severity 2
    Server 'Server name', Procedure 'bs_begin_phase', Line 0:
    Backup Server: RPC ('as_large_pagerun') execution failed.
    Server Message: Number 8009, Severity 16
    Server 'server name', Line 1:
    Error encountered by Backup Server. Please refer to Backup Server messages for details.

    so i check space space is fine. i check the log and says dump transaction log then try database dump still same error every time.
    i have tried also dbcc checkcatalog

  2. #2
    Join Date
    Feb 2002
    Willy is on vacation
    If you notice, the dump is failing exactly after 2GB size.

    Just use stripe's to solve the dump issues to keep the dump file sizes under 2GB per stripe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts