Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2006
    Posts
    23

    Unanswered: Shared DB problems

    I'm currently having problems with splitting my database.

    The situation as present it:

    - I have a shared folder on my laptop, to which i have given full permission rights to a collegue, in this folder is the backend of the db which i split from a database also sat in the shared folder

    - I can then go to the front end of my database either on my desktop or shared folder and update tables

    - However, this is where the problems start. The copy of the front end that my collegue has (an exact replica of mine) cant access or open any tables. Even if he opens the exact front end that I'm successful with in the shared folder. The following error message appears

    "Could not find the file 'D:\Test\db_be.mdb'"

    the D drive on my computer is where the shared folder 'test' is stored.

    Any hints or advice on why this isnt working?

    Thanks in anticipation

    Ross

  2. #2
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    His D:\ drive is not the same as yours.

    His front end is looking for his d:\Test folder
    so cannot find the file.

    A quick test might be to stick db_be.mdb in a folder called Test on his D drive - run it and see if it works.

    Hope that's not muddied the waters too much!

    - GeorgeV
    ----------------------------------------------------------------------------------------------------
    EDIT:
    Quote Originally Posted by rcwilkinson
    "Could not find the file 'D:\Test\db_be.mdb'"

    the D drive on my computer is where the shared folder 'test' is stored.
    YOUR D drive
    George
    Home | Blog

  3. #3
    Join Date
    Feb 2006
    Posts
    23
    thanks George, i'll try that out, unfortunately he's gone home now so I'm going to have to wait! I'll inform you of the outcome,

    thanks again

  4. #4
    Join Date
    Feb 2006
    Posts
    23
    Due to other work commitments Ive only just been able to get back to this issue. It feels like ive taken one step forward and 2 back however!

    Here is the current state of play:

    - created one table database (for testing purposes)
    - split database onto my shared folder (located myshared folder by going through Entire Network>MS Windows Network>myspecific shared folder
    - database successfully split!

    Some interesting results.... I can open my FE db and also open the table. However, I cant input any information into the table, the table headers appear but no cells below to input information, (one of the problems experienced in post above)

    Surely I have full admin rights to my folder (having just looking on security settings it appears I have.)

    Any ideas as to why its going a bit wrong?

    Thanks again

  5. #5
    Join Date
    Aug 2005
    Location
    Delaware
    Posts
    139
    RCWilkinson... I assume you are re-linking the back end each time? Even though both systems are looking for it in a D drive, you are having problems so just for kicks I would re-link again.

  6. #6
    Join Date
    Oct 2002
    Location
    Leicester - UK
    Posts
    820
    have you tried non mounted referencing?

    I've never tried this with Access, i do most of my networked DB's with SQL Server or Oracle.

    however if i want to talk to my laptop from my PC i use \\MT_Laptop\Shared\
    Definition of a Beginner, Someone who doesn't know the rules.

    Definition of an Expert, Someone who knows when to ignore the rules.

  7. #7
    Join Date
    Feb 2004
    Location
    New Zealand
    Posts
    1,424
    Provided Answers: 8
    have you

    in the user computer
    type \\MT_Laptop\Shared\ in explorer
    can you see any thing

    then what i do is right and create a text file

    if all this works them the database will
    hope this help

    See clear as mud


    StePhan McKillen
    the aim is store once, not store multiple times
    Remember... Optimize 'til you die!
    Progaming environment:
    Access based on my own environment: DAO3.6/A97/A2000/A2003/A2007/A2010
    VB based on my own environment: vb6 sp5
    ASP based on my own environment: 5.6
    VB-NET based on my own environment started 2007
    SQL-2005 based on my own environment started 2008
    MYLE
    YOUR PASSWORD IS JUST LIKE YOUR TOOTHBRUSH DON'T SHARE IT.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •