Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2007
    Posts
    2

    Unanswered: OCIDescribeAny with Database Alias

    Hi,

    I have an issue which I really hope someone can help me with.

    I support a piece of software which connects to an Oracle database, normally this works fine however if you change the Oracel datbase name in tnsnames.ora to an Alias I get the following error:-

    ORA-04043: object TESTDB_FAIL does not exist

    and a subsequent error stating that this is caused when trying to call OCIDescribeAny.

    I can connect to the the database TESTDB_FAIL using sqlplus etc. If I change the name back in tnsnames.ora to the actual database name it works fine and connects without any problem.

    My quesiton is:-

    Is there a known limitation with changing the ALias for a datbase when using OCIDescribeAny? and is there a way of getting round this?

    Thanks in advance for any advice. As you may have guessed I only have very limited Oracle skills so be gentle on me

  2. #2
    Join Date
    Aug 2004
    Location
    France
    Posts
    754
    Are you sure that you are currently using the tnsnames.ora file ?

    Can you check if the TNS_ADMIN environment variable is correctly set to the directory containing your tnsnames file ? (on Windows, you can use either an environment variable or a registry key)

    Regards,

    rbaraer
    ORA-000TK : No bind variable detected... Shared Pool Alert code 5 - Nuclear query ready .

  3. #3
    Join Date
    Feb 2007
    Posts
    2
    Hi rbaraer,

    Many thnaks for your reply. I do not have the environment variable TNS_ADMIN set at all. Does it not have a default directory is this environment variable is not set? It seems to pick up the name in all other case apart from if the alias is different form the actual database SID.

    thanks
    Tinx

  4. #4
    Join Date
    Aug 2004
    Location
    France
    Posts
    754
    Sorry, I haven't been there for a while... Did you solve your problem ? If so, can you share ?

    Regards,

    rbaraer
    ORA-000TK : No bind variable detected... Shared Pool Alert code 5 - Nuclear query ready .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •