DB2 8.2 -> DB2 9.1 AIX 5.3 for SAP

Hey all, I'm trying to run a test install of LUW 9.1. I'm using the ESE AIX_64 version supplied by SAP.

I'm pretty new to AIX so my question is.... what is the right choice for licensing? We are licenced for 8.2 and our account manager seems to think this covers us for 9.1 so do I try and find the old .lic file somewhere? Should I try and remove licensing and use "Try and Buy" mode (db2licm -r)? Or should I be getting a new licence file from IBM or SAP (I looked on the CD, no joy)?