Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2006
    Posts
    2

    Unanswered: db2 9.1 error msg.

    Hi,

    We are doing the migration activity on server which is running db2 8.1 to another new server which has installed with db2 9.1 and after successfull migration, below error is getting while running the command "db2 get admin cfg"

    $ db2 connect to MAINSRV

    Database Connection Information

    Database server = DB2/AIX64 9.1.0
    SQL authorization ID = DB2xxxx
    Local database alias = MAINSRV

    $ db2 get admin cfg
    SQL22204N The DB2 Administration Server encountered a non-severe error while
    executing a request.

    But at the same time, could able to get other confi. like db2 get db cfg and db2 get dbm cfg .

    Solution,
    Infact stop the db2 and started it again but still the same problem
    also checked the persmission on dasuser id, instance id and fenced id but all the persmission is same as source server.

    Pls can any one help and direct me to isolate the problem and or solve the smae..

    Thanks in advance...

    Regards
    sasubbar

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    My guess is that the DB2 admin server is not running. Log in as the das user and issue: db2admin start

    Andy

  3. #3
    Join Date
    Oct 2006
    Posts
    2

    db2admin start error - db29.0

    Hi Andy,

    Thanks for prompt response..

    I have checked the server and provide the current status below

    $ pwd
    /home/dasusr1/das
    $ whoami
    dasusr1
    $ ps -ef | grep dasusr1
    dasusr1 180346 454756 0 21:54:56 pts/1 0:00 grep dasusr1
    dasusr1 315606 1 0 Mar 08 - 0:00 /home/dasusr1/das/adm/db2dasrrm
    dasusr1 377016 1 0 Mar 08 - 0:03 /opt/IBM/db2/V9.1/das/bin/db2fmd -i dasusr1 -m /opt/IBM/db2/V9.1/das/lib/libdb2dasgcf.a
    dasusr1 417996 454756 0 21:54:56 pts/1 0:00 ps -ef
    dasusr1 454756 524406 1 21:23:53 pts/1 0:00 -ksh
    $ ipcs -am | grep dasusr1
    $ db2admin start
    ksh: db2admin: not found.
    $

    Do anyone feel is it a profile issue or some other..

    pls help

    Thanks

    Regards
    sasubbar

  4. #4
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Yes, it sounds like the profile for dasusr1 is not set properly.

    Andy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •