Results 1 to 14 of 14
  1. #1
    Join Date
    Mar 2007
    Posts
    37

    Red face 10g Form: Listener Problem

    hello everybody! i created a form in Oracle 10g (first time in my PC). but when compiled it and ran it, the following message appeared.
    FRM-10142: The HTTP Listener is not running on MATAL at port 8889. Please start the listener or check your runtime preferences.
    then i started OC4J instances and disabled my firewall. tried to run that again. but this time, a web page occured (my browser is IE7) as follows.
    <html> <head> ORACLE FORMS.</head>
    <body onload="document.pform.submit();" >
    <form name="pform" action="http://MATAL:8889/forms90/f90servlet" method="POST">
    <input type="hidden" name="form" value="G:\MSc\Modern Database Systems\Assignment\CourseAuth.fmx">
    <input type="hidden" name="userid" value="SYSTEM/RAHAN@rahan">
    <input type="hidden" name="obr" value="yes">
    <input type="hidden" name="array" value="YES">
    </form> </body></html>
    my listener.ora file is as follows.
    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 127.0.0.1)(PORT = 1521))
    )
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
    )
    )

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = E:\oracle\ora92)
    (PROGRAM = extproc)
    )
    )
    and tnsnames.ora file is as follows.
    RAHAN =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = RAHAN)
    )
    )

    EXTPROC_CONNECTION_DATA =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = PLSExtProc)
    )
    )
    any help will be appreciated...

  2. #2
    Join Date
    Feb 2007
    Posts
    71
    am not so sure but I think I encountered a similar problem before, if you are using windows, please ensure that the OracleService<SID> is started before running your application.

  3. #3
    Join Date
    Mar 2007
    Posts
    37
    yeah, i have assured that the service is running. i had to change the tnsnames.ora and listener.ora files to make oracle running on my windows xp. i think something is screwed up over those 2 files.

  4. #4
    Join Date
    Feb 2007
    Posts
    71
    have you tried checking ORACLE_SID environment variable if its properly configured to the database you're connecting to? PLUS before, I encountered almost similar error when running Enterprise Manager. It warned me of unstarted listener so i just executed LSNRCTL START and it worked. You think it would work on your side?

  5. #5
    Join Date
    Mar 2007
    Posts
    37
    oooh! wait a minute! i restarted the service and tried again. this time, it even cannot connect with the database! form is now providing following error message!! my goodness! what have i done?
    ORA-12154: TNS: could not resolve service name

  6. #6
    Join Date
    Mar 2007
    Posts
    37
    actually i am jaded trying things again and again for oracle... can you take a look at those 2 files please? i think that is the sprout of all evil! my service name is RAHAN. database name is RAHAN. password is as well RAHAN. it ran at last when i first posted the message, now even it is not connecting with database!

  7. #7
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,628
    >FRM-10142: The HTTP Listener is not running on MATAL at port 8889. Please start the listener or check your runtime preferences.
    I'll be the 1st to admit that the above line is somewhat misleading.
    The top line has NOTHING to do with any Oracle listener!!!!!!
    > action="http://MATAL:8889/forms90/f90servlet" method="POST"
    The line immediately above requires Apache (or some webserver) to be running & "listening" on port 8889 or it will fail every time.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    There are no stupid questions, but there are a LOT of Inquisitive Idiots.

  8. #8
    Join Date
    Mar 2007
    Posts
    37
    The line immediately above requires Apache (or some webserver) to be running & "listening" on port 8889 or it will fail every time
    i installed apache. but how can i make it to listen on port 8889?

  9. #9
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,628
    Whole books have been written on how to configure & manage Apache.
    I am not about to excerpt the appropriate passages just for you here.
    The file is httpd.conf & IIRC the line in question will contain the string "PORT".
    http://apache.org
    and/or
    http://google.com
    should provide all the answers you need.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    There are no stupid questions, but there are a LOT of Inquisitive Idiots.

  10. #10
    Join Date
    Mar 2007
    Posts
    37
    well, i think i sorted out the problem. i did not have jinitiator (i did not know anything about it) when i pressed http://matal:8889/forms90/f90servlet from my very first post, it said i require jinitiator. i installed that. but still it is showing that the page is opening, but it never opens... i tried that with mozilla firefox as well (by disabling java in firefox), seeing the solutions in http://forums.oracle.com/forums/thre...hreadID=486254
    but still it is not working for me....
    i think the problem specified in that link and mine, is same, but he got the solution, i am sitting duck!

  11. #11
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,006
    Did you start the OC4J instance?

  12. #12
    Join Date
    Mar 2007
    Posts
    37
    Did you start the OC4J instance?
    yeah mate, i started that. you can find that in my first post.

  13. #13
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,006
    Oh, right ... if I only had paid more attention.

  14. #14
    Join Date
    Mar 2007
    Posts
    37
    well, it is running now. all i did is-
    1. uninstall 10g and 10g developer
    2. install 10g XE and 10g developer
    3. change the tnsnames.ora and listener.ora files
    4. switch to IE6
    5. install jinitiator again (though it should have installed with developer suite)
    6. smile when the forms ran

    hope this will be helpful for some other bewildered...thanks guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •