Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2007
    Posts
    2

    Unanswered: max_enabled_roles value

    Please, How I can to change max_enabled_roles value? Please excuseme, but my english is so bad!

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Set its value in INIT.ORA. This parameter is deprecated in Oracle 10g.

  3. #3
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >This parameter is deprecated in Oracle 10g.
    Really!
    http://download-west.oracle.com/docs...tparams117.htm
    Last edited by anacedent; 04-03-07 at 02:43.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  4. #4
    Join Date
    Jul 2006
    Posts
    49
    You did not specify a version of Oracle. As others have noted it cannot be set in Oracle 10g. In Oracle 9i it depends if you are using a init.ora file or a SPFILE.

    Most people set this parameter to a two digit number like 50. The max value is 148. The parameter is static, which means the changes will not take effect until after you shutdown and restart the instance.

    If using a init.ora file then
    a. edit the file in a text editor
    b. search for max_enabled_roles. If found you can change the value. If not found then add the line ...
    max_enabled_roles=100
    c. shutdown the instance and restart it.

    If using a SPFILE then
    a. launch sqlplus and connect as any DBA or SYSDBA user.
    b. issue the following command ...
    alter system set max_enabled_roles=75 scope=spfile sid='*';
    c. shutdown the instance and restart it.

  5. #5
    Join Date
    Mar 2007
    Posts
    2

    Thanks!

    Thanks to all people who help me. My Oracle version is 9i and use Spfile. Then I resolve my problem using SQL command "Alter system set max_enabled_roles = 130...". Thanks Remidata!

    Muchas gracias a todos! je! je! This is my language.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •