Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2007

    Unanswered: ADODB.Connection error '800a0e7a'


    I have a ASP website installed on Windows 2003 using Microsoft Access. Now it had been working until yesterday when a windows update suddenly resulted in this error on all DB connected ASP pages:

    ADODB.Connection error '800a0e7a'

    Provider cannot be found. It may not be properly installed.

    /includes/, line 12

    After pouring over forums, I have come to learn that the MDAC is corrupted. I had 2.8 previously installed. After trying to re-nstall MDAC with no success, I tried installing Windows 2003 Service Pack 2. I believe this is supposed to install MDAC 2.8 service pack 2. This also gets the latest Jet 4.0 engine. On running Component Checker, the version comes up as UNKNOWN, but I am guessing that this is because the service pack was released recently and is therefore unrecognized.

    However, after all this, I still get the same error and for the life of me cannot figure out what to do. Could anyone please help!!

    P.S. My connection strings(which were working) are of the form:
    Set oConn = Server.CreateObject("ADODB.Connection")
    = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source="&sDBPath&";Persist Security Info=False"
    oConn.Open connString

  2. #2
    Join Date
    Nov 2004
    It sounds that all the usual advice about checking MDAC, reinstall etc is already tried, then there's the extreme versions - I think you're ready for what this user experienced (from one of Microsoft public NGs)

    (here's a thread going through much of the regular stuff, without success

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts