Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2007
    Posts
    3

    Red face Unanswered: SQL Server 2005 Express

    Hi,
    I am attempting to create a database.I have tried several different remedies and find myself just digging a deeper hole. This is my error message:
    An attempt to attach an auto-named database for file (then my file name)A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.

    I have tried giving me an administer status in the Asp.net config file by using the tool provided Website-Asp.net config

    I have tried given myself additional security by going to the SQL Server Manager Express.

    I have tried rewriting my whole data base from scratch, the final time without any coping and pasting as this was presented as a posible cause.

    I have tried reinstalling my Sql server.

    I have formated my drives twice and reinstalled Windows and then SqL on a fresh drive.

    I have tried an additional drive that I used for backup only, put windows on that and tried to install everthing fresh to that.

    I tried install murach version of the Database Holloween. Used their attach database and grant permissions. Which always worked before and am getting these additional errors in the grant permissions:
    Msg 15401, Level 11, State 1, Procedure sp_grantlogin, Line 49
    Windows NT user or group '[machineName]\ASPNET' not found. Check the name again.
    Msg 15401, Level 11, State 1, Procedure sp_grantlogin, Line 49
    Windows NT user or group '[machineName]\ASPNET' not found. Check the name again.
    Msg 15401, Level 16, State 1, Line 1
    Windows NT user or group '[machineName]\ASPNET' not found. Check the name again.
    Msg 15410, Level 11, State 1, Procedure sp_addrolemember, Line 75
    User or role '[machineName]\ASPNET' does not exist in this database.
    Msg 156, Level 15, State 1, Line 2
    Incorrect syntax near the keyword 'exit'.


    So you can see I'm in a very deep hole, can anyone help me out.

  2. #2
    Join Date
    Mar 2007
    Location
    Holmestrand, Norway
    Posts
    332
    IT appears that the application expects to run as a user called named ASPNET, which apparently does not exist. Check the operating system and add the user. This process is most likely described in the software manual.
    Ole Kristian Velstadbråten Bangås - Virinco - MSSQL.no - Facebook - Twitter

  3. #3
    Join Date
    Apr 2007
    Posts
    3
    I have tried making changes to my name in SQL server manager to grant me permissions the \ ASPNET was what the textbook had told me to put in after I entered the name of my coumputer.This had worked before but it dosn't seem to help now. Then I tried just entering my computer name still no luck I do not go to school I'm retired and I do this as a hobby.
    So I don't have a teacher I can go to. I just go to forums and read books I would really appreate if any of you guys would have some answers for me.

  4. #4
    Join Date
    Mar 2007
    Location
    Holmestrand, Norway
    Posts
    332
    Have you tried my approach? It's obvious that you have to change [machineName] to the actual name of your computer, and I'm still pretty convinced that you have to create the local user account ASPNET first. Have you verfied that it exists?
    Ole Kristian Velstadbråten Bangås - Virinco - MSSQL.no - Facebook - Twitter

  5. #5
    Join Date
    Apr 2007
    Posts
    3
    I seem to have that one resolved by granting permissions to the ASP.Net folder itself. I had the permissions granted to just my computers name(Machine Name) and also to my computers name with \ASPNet following. I appreaciate your help. I am now working on a problem to resolve an issue which error message states:
    An attempt to attach an auto-named database for file (Then my file)failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.

    I am thinking this may be a result of coping and pasting some of my previous web site to create a new one on my other drive I am now starting my whole project from scratch no coping and pasting since I haven't came to the instalation of my database yet I can't tell you if this works. Thanks again I'll just keep trucking along here. Let me know if you have any answers for this one or think I'm on the wrong track though... Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •