Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2007
    Posts
    3

    Unanswered: CPAN Installation error

    Hi,

    I installed manually the CPAN and getting the errors as shown below, Please let me know what I am missing (i know Makemaker and I installed and installed the module it fails when i make it.). Thanks in advance for any help.

    # cd /CPAN-1.9101
    # ls
    ChangeLog MANIFEST PAUSE2003.pub SIGNATURE lib
    ChangeLog.old MANIFEST.SKIP PAUSE2005.pub Todo scripts
    Changes META.yml PAUSE2007.pub distroprefs t
    Changes.old Makefile.PL README inc
    # perl Makefile.PL
    Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/perl5/5.6.1/lib/sun4-solaris-64int /usr/perl5/5.6.1/lib /usr/perl5/site_perl/5.6.1/sun4-solaris-64int /usr/perl5/site_perl/5.6.1 /usr/perl5/site_perl /usr/perl5/vendor_perl/5.6.1/sun4-solaris-64int /usr/perl5/vendor_perl/5.6.1 /usr/perl5/vendor_perl .) at Makefile.PL line 5.
    BEGIN failed--compilation aborted at Makefile.PL line 5.

    Regards,

    zvohra

  2. #2
    Join Date
    Oct 2002
    Location
    Baghdad, Iraq
    Posts
    697
    i know Makemaker and I installed and installed the module it fails when i make it.

    The "it" that fails is confusing me. Are you saying that you installed Makemaker and that the installation of CPAN fails or that you couldn't install Makemaker?

    Anyhow, verify that:

    You actually need to install CPAN. Try running "cpan".

    You're trying to install CPAN to the right version / copy of Perl. Many systems have multiple versions of Perl installed in all different places. perl -v helps here.

    Your PERL5LIB or PERLLIB is set correctly, if needed. See perldoc perlrun.

    You are running with enough permissions, i.e. you don't need to run su or something. If you're trying to install a module to a /usr copy of perl, you probably need to be the admin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •