Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2006
    Posts
    8

    Unanswered: sorted_data option taking more time

    Hi Folks..
    Need you help.I am in strange dilemma.

    I used to think that creating clustered index with sorted_data option will take less time but unfortunately this is not happenning. It is taking more time than otherwise. I checked the physical_io from master..sysprocesses that this commands take and strangly the physical_io for sorted_data option was nearly 450000 whereas without sorted_data option, physical_io is only 75000.

    I have no way to check the logical IO.

    'set statistics io on' does not show statistics for create index command.

    Is there any setting that need to be done . The table is AllPages locked table.

    Please help.

  2. #2
    Join Date
    Mar 2007
    Posts
    72
    A clustered index means that all entries on a data page are in index key order. So why do you again specify sorted-data during index creation, this is additional overhead as it is superfluous. This is why it uses more physical I/O.

  3. #3
    Join Date
    Jan 2006
    Posts
    8
    Quote Originally Posted by sudarao
    A clustered index means that all entries on a data page are in index key order. So why do you again specify sorted-data during index creation, this is additional overhead as it is superfluous. This is why it uses more physical I/O.
    Oh.. really..
    Did you understand the question?

  4. #4
    Join Date
    Feb 2005
    Location
    Omaha, NE
    Posts
    83
    Interesting. What version of ASE ?

    Quote Originally Posted by Nishant Gourav
    Hi Folks..
    Need you help.I am in strange dilemma.

    I used to think that creating clustered index with sorted_data option will take less time but unfortunately this is not happenning. It is taking more time than otherwise. I checked the physical_io from master..sysprocesses that this commands take and strangly the physical_io for sorted_data option was nearly 450000 whereas without sorted_data option, physical_io is only 75000.

    I have no way to check the logical IO.

    'set statistics io on' does not show statistics for create index command.

    Is there any setting that need to be done . The table is AllPages locked table.

    Please help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •