I had to import delimited data with the tilde "~" as delimiter
Straightforward it worked on one CSV-file.

Then I added an identity field to the table and changed the mapping in the format file, and suddenly it all broke down.
"wrong column number etc.." message.

It's not really urgent because i solved the issue by whacking everything in a one column temp-table, and splitting it into columns from there.
This seems the only option anyway, since sometimes I receive a file with 57 columns and sometimes it's 60.
Probably the difference is due to distributing the processing load at the producing agency side, but the difference doesn't (AFAIK) allow me to use BCP with format file anyway (given the mix of 57 and 60 columns input files)