Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2007
    Posts
    2

    Unanswered: Problem to connect into a SQL DB

    Hi,

    I have this problem:

    I have install the SQL Server Enterprise Manager on a Windows 2003 server with ISA 2004 and I try to connect two different SQL server 2000
    One I can reach the other one I receive the message "Timeout expired"
    With the same user from my PC running Windows XP I connect in the two SQL server

    From ISA server I can ping the two SQL server and from the two SQL server I can ping the ISA server

    With ODBC I can connect if I choose Name pipes its work fine, when I try with TCP/IP it doesn't work

    somebody can help me?

    thanks
    Athos

  2. #2
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Check what protocols have been enabled on SQL SErver by using server network utilityand enable named pipes or tcp/ip as per your requirement.

    You may use SQLSetStmtAttr to set the timeout value (SQL_ATTR_QUERY_TIMEOUT):
    http://msdn2.microsoft.com/en-us/library/ms712631.aspx
    fyi.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  3. #3
    Join Date
    Jul 2007
    Posts
    2
    I verify using server network utility but TCP/IP on the server are enable.
    The strange is that one time I can reach the server but five minute later I have the error on the SQL Server Enterprise Manager that you find on the attached file

    I try with SQL Query Analyzer to connect with a user that belong to the group domain admins and I receive this error:

    Unable to connect to Server "ServerName":

    Server: Msg 17, Level 16, State 1
    [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]SQL Server does not exist or access denied

    this error I have from my ISA2004 server
    from my PC running windows XP I don't have this problem and I use the same user

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •