Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2007

    Unanswered: problem in running shell script from CRON

    Hi I am facing problem in running cron jobs which actually calls a shell script .

    Can anyone help as i am new to unix .

    Whenever i run the cron job it does nothing .
    I see that the shell is called but don't know why it is not getting executed.
    But when i run the shell independently it executes .
    Pls let me know in details the problem adn the soltuion .
    Kindly help it is urgent .

    yes one more thing
    I have made a in which i have declared all databse connection , java path , class path etc and use it in the shell script --- is that the reason ??
    Last edited by shuzghun; 07-13-07 at 15:22.

  2. #2
    Join Date
    Aug 2006
    The Netherlands

    Are all the env.variables needed by the shell set in the script or sourced from another file? A shell started by cron doesn't read the .profile and therefore hasn't got the usual settings.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts