Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2006
    Posts
    6

    Unanswered: I cant use isqlplus

    Hello
    OS: Windows XP
    DB: Oracle 9i 9.2.0.1


    I cant connect to my DB using isqlplus. I type "http://spring:7778/isqlplus/" and it doesnt work. The browser shows nothing. Spring is my computer name. SQL* PLUS can work. iSqlplus can not work.

    I figure out there are some problems with http server. Here is the error message:
    Code:
          [Mon Jul 23 10:37:04 2007] [alert] (5)存取被拒。: FastCGI: CreateMutex() failed
          Syntax error on line 92 of c:/oracle/ora92/sqlplus/admin/isqlplus.conf:
          failed to create FastCGI application accept mutex
    Here is content of isqlplus.conf:

    Code:
          #
    # Copyright (c) 2001, 2002, Oracle Corporation.  All rights reserved.  
    #
    # NAME
    #   isqlplus.conf
    #
    # PURPOSE
    #   Oracle HTTP Server directives for the iSQL*Plus server
    #
    # USAGE
    #   This file should be included in the Oracle HTTP Server
    #   "oracle_apache.conf" file.
    
    
    #
    # Enable handling of all virtual paths beginning with "/iplus/"
    #
    # Note: only /iplus/ is mapped, /iplus is not being mapped
    #
    <IfModule mod_alias.c>
      Alias /iplus/ "C:\oracle\ora92\sqlplus\admin\iplus/"
    
      # Disallow users from trying to access /iplus/ directory listing
      <Directory "C:\oracle\ora92\sqlplus\admin\iplus">
         AllowOverride None
         Options FollowSymLinks
         Order deny,allow
         Allow from all
      </Directory>
    </IfModule>
    
    
    #
    # Maps all virtual paths beginning with "/isqlplus*" to the iSQL*Plus
    # FastCGI application
    #
    <IfModule mod_alias.c>
      ScriptAliasMatch ^/isqlplus(.*)    C:\oracle\ora92\bin\isqlplus
      ScriptAliasMatch ^/isqlplusdba(.*) C:\oracle\ora92\bin\isqlplus
    
      <Directory "C:\oracle\ora92\bin">
         AllowOverride None
         Options FollowSymLinks
         Order deny,allow
         Allow from all
      </Directory>
    </IfModule>
    
    
    #
    # Enable handling of all virtual paths beginning with "/isqlplus"
    #
    <Location /isqlplus>
      SetHandler fastcgi-script
      Order deny,allow
    
      # Comment "Allow ..." and uncomment the four lines "AuthType ..."
      # to "Require ..." if Oracle HTTP authentication access is required
      # for the http://.../isqlplus URL
      Allow from all
      #AuthType Basic
      #AuthName 'iSQL*Plus'
      #AuthUserFile C:\oracle\ora92\sqlplus\admin\iplus.pw
      #Require valid-user
    </Location>
    
    
    #
    # Enable handling of all virtual paths beginning with "/isqlplusdba".
    #
    # Note: Oracle HTTP authentication access must be configured to
    #       prevent unauthorized users performing DBA operations on
    #       the database
    #
    # Use the HTTP server utility script "htpasswd" to add users to the
    # "iplusdba.pw" file.
    #
    <Location /isqlplusdba>
      SetHandler fastcgi-script
      Order deny,allow
      AuthType Basic
      AuthName 'iSQL*Plus DBA'
      AuthUserFile C:\oracle\ora92\sqlplus\admin\iplusdba.pw
      Require valid-user
    </Location>
    
    
    #
    # Setup the iSQL*Plus FastCGI application.
    #
    <IfModule mod_fastcgi.c>
      FastCgiServer C:\oracle\ora92\bin\isqlplus -port 8228 -initial-env iSQLPlusNumberOfThreads=20 -initial-env iSQLPlusTimeOutInterval=30 -initial-env iSQLPlusLogLevel=off  -initial-env iSQLPlusAllowUserEntMap=none -idle-timeout 3600
    </IfModule>
    Thank you for help.
    Last edited by mayumifan; 07-23-07 at 13:43.

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >Any one can help?
    Nope

    You need to read & follow the #1 STICKY post at the top of this forum.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    "It doesn't work" is less than descriptive. What does it mean? Did you get an error message? If so, which one was it?

    "spring" is the localhost (actually, you are not quite sure it is). Do you have its alias in the hosts file? If not, you might try with 127.0.0.1 (instead of "spring").

    Are you sure that port 7778 is the correct one?

    Just being curious: what's wrong with SQL*Plus?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •