Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2007
    Posts
    18

    Unanswered: "Enter Parameter Value" dialog boxes appeared on the screen during form opening

    I have a form that is having some other forms in it. when i open that form a dialog box appears and . it asks for "Enter parameter value".
    and i think in imported forms i do have that parameter as a hidden field.

    is there any way that i could initialize that parameter during runtime of my main form. in my vba code. while still having those other forms included in the main form.
    Thanks

  2. #2
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926
    If you are getting an "Enter parameter value:" prompt then somewhere in some form, Access is not recognizing the field name you've supplied. It could be in the Record Source Query of some form somewhere or a list box rowsource query, the Control Source of a field, an expression for a Control Source for a field, or even in the Conditional Formatting expression of a field (plus a few other places I've probably forgotten about).

    Once you find out where the error is, fix it with the correct field name. If the field is on the form but is hidden, I don't believe you should be getting the prompt for a parameter from that cause.
    Last edited by pkstormy; 08-06-07 at 17:04.
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

  3. #3
    Join Date
    Jul 2007
    Posts
    18
    Actually I am trying to somehow relate different forms with issue_number.
    Now I have imported 4 forms in main form. And i want them to not to fetch the data with which they are bound via RowSource property. I want all of them to be blank for me as the first time i m trying to enter the new record in my dtabase. But when i just import them without issue_number. they show all the records.which i dont want. So i used issue_number to make them coherent but unable to provide its value.
    Neither i could use DoCmd in which i could provide the criteria.

    So this is why it keeps asking me issue_number 4 times.

    is there anyother way to resolve this issue?

  4. #4
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926
    I'm a little bit confused when you say you have imported 4 forms in main form. If there is some problem with the subforms which I'm guessing you're trying to relate, you can make the source object of the subform blank on the main form and then issue a me.mysubformname.sourceobject = "MySubformName" command when appropriate.
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

  5. #5
    Join Date
    Jul 2007
    Posts
    18
    Everything was working good whn i had Access as Front end and backend.
    Now I have adp and sql server.
    And so its giving me an error.
    And i did change the row source property to blank becz it was dispalying all the 5000 records which is unnecessary to dispaly when you are entering a brand new record.
    To get rid of it i change the row source property to blank and now saving the data via Insert command.
    Everything else is working good except that i m unable to enter the data in the forms i imported (They were working good before).
    It keeps asking for issue_number. If i press cancel it shows me white blank. but when i press ok. it does show me the columns but doesnt show me the place to enter the data and this is all of coz of issue_number.

    is that a better explan of my prb/?????

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •