Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2007
    Posts
    17

    Unanswered: ORA-02404: specified plan table not found

    When I try to execute any sql through TOAD i get this error:
    ORA-02404: specified plan table not found

    I tried running TOADPREP.sql/NOTOAD.sql. But it gives missing keyword error.

    Could u help me out with this please?

    Regards,
    Sajita

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Those who live by the GUI, die by the GUI.
    SQL*Plus is more reliable & less problematic.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Any query? Did you, somehow, unintentionally turn "Explain Plan" option ON? Switch it OFF!

    Problem might be in plan table's name; try to create it using the [CODE.RDBMS]UTLXPLAN.SQL script, just change table's name from PLAN_TABLE to TOAD_PLAN_TABLE.

  4. #4
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    Quote Originally Posted by anacedent
    Those who live by the GUI, die by the GUI.
    SQL*Plus is more reliable & less problematic.
    I agree 100%. There are going to be times when a gui is unavailable and you have to know the commands and their syntax. I use GUI's myself about 25% of the time. But good old SqlPlus is normally faster to use then having to navigate the menus in the GUI.
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  5. #5
    Join Date
    Jun 2007
    Posts
    17
    Quote Originally Posted by Littlefoot
    Any query? Did you, somehow, unintentionally turn "Explain Plan" option ON? Switch it OFF!

    Problem might be in plan table's name; try to create it using the [CODE.RDBMS]UTLXPLAN.SQL script, just change table's name from PLAN_TABLE to TOAD_PLAN_TABLE.
    Thanks... I had, inadvertently, switched on Explain Plan. Turned it off and now its working fine...

    Thanks a ton...

    Regards,
    Sajita...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •