Results 1 to 3 of 3
  1. #1
    Join Date
    May 2007
    Posts
    6

    Unanswered: strange behaviour, table names with spaces

    Hi all,

    I'm using ASE 12.5.2 and am facing a situation where I need to rename a table name to another name. I tried using sp_rename but in the table names I need to use contain blank spaces (e.g. "Runaway Train"). I've tried enclosing them with double quotes but the table gets renamed with the quotes i.e the tablename displayed in the dbase displays quotes as well. When I try to use sp_help to check the table I get a message that the table does not exist.

    Is there another way to handle table names with spaces? I tried looking up the forum but could'nt find clues. Any help will be appreciated.

    Thanks in advance.

    M

  2. #2
    Join Date
    Jun 2007
    Location
    London
    Posts
    2,527
    I'd suggest saving yourself a whole lot of grief by just calling the table Runaway_Train or RunawayTrain. It's the same thing with fields having spaces - it's a pain to implement, a pain to work with and, at the end of the day, offers no advantages to anyone.

    Mike

  3. #3
    Join Date
    May 2007
    Posts
    6
    Thanks for replying mike. Yeah I had been thinking on the same lines too. I was trying to make minimal changes to the functionality of the existing code hence the question. Guess I'll have to drop usage of whitespace alltogether.

    Cheers,

    M

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •