Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2007

    Question Unanswered: Error in setting permissions on file/directory $ORACLE_BASE/jre/1.1.8/LICENSE


    On installing Oracle 9.2 on RedHat Linux release 4, I encounterd the
    following error:

    ************************************************** *********************
    Error in setting permissions on file/directory

    ************************************************** ***********************
    This error is encountered at the inital stage of installation after inputing all the
    required settings in the OUI. and at the Installing Java Runtinme Environment

    Could someone tell me why it happened and how to fix it? Your help is
    much appreciated.

    There was a post on this topic only in here and said to change the permissions of the
    ORACLE_BASE .......... I have tried out all these and all the permissions and the environment settings are correct but i'm not able to proceed with the installation even after a lot of trying.

    All you guys help is verry verry appresiated..........


  2. #2
    Join Date
    Aug 2007
    hi all........... found out the reason for this erroe after a lot of trails and finally succeeded.

    if u have copied the oracle 9i dump into say a pen drive or an external hard disk and
    before installing in ur local machine if u copy the dump onto the hard disk of ur local
    machine and try to install from there u get this error

    Instead u try to install the s/w from the pendrive or the external hard disk itself you
    will not get the err.


  3. #3
    Join Date
    Nov 2008

    Re: Error in setting permissions on file/directory

    First of all, this error message is misleading(atleast in my case).There was write permissions in the target directory and i was able to create files in that directory without any problems as the oracle user manually.The problem actually lies in the source directory from where the installer tries to copy this files to the target directory.In my case the source directory contained the file "license" instead of the uppercase "LICENSE".I renamed the file "license" in the source directory to uppercase "LICENSE" and clicked "Retry" and the problem was solved.After solving this error, you will get similar errors for other files in that source directories which all has got this same problem.Just rename the corresponding files to the uppercase versions and it will install without any problems.

    Your source directory will be under your installation directory tree(under Disk1).Just find the corresponding lowercase files and rename it, and you are done!!

    This problem might have occured because of copying the oracle installation files from a windows partition to linux partition.(for eg: from a pendrive)

    Sreejith V

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts