Results 1 to 12 of 12
  1. #1
    Join Date
    Feb 2007
    Posts
    31

    Thumbs up Unanswered: Create tablespace privileges

    Hi,
    My User 'A' having local admin right on my PC(XP -professional)and it is a part of a domain User. I installed UDB V8.2 in my PC. Automatically it created a group called DB2ADMNS. Then I added my user 'A' in that group DB2ADMNS and i ran this command ..
    db2 update dbm cfg for SYSADM_GROUP DB2ADMNS

    It ran successfully...

    When Iam trying to create a tablespace form my User 'A' it is showing this error..

    C:\Documents and Settings\A>DB2 "CREATE REGULAR TABLESPACE STORE MANAGED BY DATABASE USING (FILE 'DB2\NODE0000\SQL00001\SQLT0001.0\STORE.DBF' 512)"
    DB21034E The command was processed as an SQL statement because it was not a
    valid Command Line Processor command. During SQL processing it returned:
    SQL0552N "A" does not have the privilege to perform operation "CREATE
    TABLESPACE". SQLSTATE=42502

    Note:Iam able to create tables.


    Can any please help on this problem.
    Regards
    Mohan

  2. #2
    Join Date
    Jun 2006
    Posts
    471
    according the doc
    The privileges held by the authorization ID of the statement must include SYSCTRL or SYSADM authority.
    Best Regards, Guy Przytula
    DB2 UDB LUW certified V6/7/8

  3. #3
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    I suspect the problem may be caused by the location where you are attempting to create the container. Did you try to create the new tablespace container in another location, which is not being used as a container for TEMPSPACE1?
    ---
    "It does not work" is not a valid problem statement.

  4. #4
    Join Date
    Feb 2007
    Posts
    31
    1. User 'A' is part of SYSADBM ...

    2.I ran the above command from db2admin user... It ran successfully...(Then there is no problem in the container also)...

    Can you please help on this prblm....
    Regards
    Mohan

  5. #5
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Please provide the output of "dbset -all"
    ---
    "It does not work" is not a valid problem statement.

  6. #6
    Join Date
    Jan 2007
    Location
    Jena, Germany
    Posts
    2,721
    Quote Originally Posted by d_mohan81
    1. User 'A' is part of SYSADBM ...
    What is the DBM CFG parameter SYSADM_GROUP set to? And does 'A' belong to the group specified there?
    Knut Stolze
    IBM DB2 Analytics Accelerator
    IBM Germany Research & Development

  7. #7
    Join Date
    Feb 2007
    Posts
    31
    1.
    C:\Documents and Settings\A>db2set -all
    [e] DB2PATH=D:\Program Files\IBM\SQLLIB
    [i] DB2ACCOUNTNAME=01HW050390\db2admin
    [i] DB2INSTOWNER=01HW050390
    [i] DB2PORTRANGE=60000:60003
    [i] DB2INSTPROF=D:\PROGRA~1\IBM\SQLLIB
    [i] DB2COMM=TCPIP
    [g] DB2_EXTSECURITY=YES
    [g] DB2_GRP_LOOKUP=LOCAL
    [g] DB2SYSTEM=01HW050390
    [g] DB2PATH=D:\Program Files\IBM\SQLLIB
    [g] DB2INSTDEF=DB2
    [g] DB2ADMINSERVER=DB2DAS00

    2.
    SYSADM group name (SYSADM_GROUP) = DB2ADMNS
    SYSCTRL group name (SYSCTRL_GROUP) =
    SYSMAINT group name (SYSMAINT_GROUP) =
    SYSMON group name (SYSMON_GROUP) =

    The User 'A' belong to DB2ADMNS group..

    Lookiing for your advices..to reslove the problem..
    Regards
    Mohan

  8. #8
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    A very basic q ..

    Did you restart the instance after changing the parm ?
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  9. #9
    Join Date
    Feb 2007
    Posts
    31
    Yes I restared the instance as well as database ALSO....

    Note:
    I thik there is problem with my user id 'A'..Because my user 'A' is a part of domain and does not have the admin privillage for that Domain.But I have admin privleges for my local system.

    Please help me on this prblm
    Regards
    Mohan

  10. #10
    Join Date
    Jun 2006
    Posts
    471
    maybe this setting can help
    For example, if a user logs on to a domain account and tries to access a DB2 database, DB2 goes to a domain controller to enumerate groups (including the Administrators group). You can force DB2 to always perform group lookup on the local computer by setting the registry variable DB2_GRP_LOOKUP=local and adding the domain accounts (or global groups) to the local group.
    Best Regards, Guy Przytula
    DB2 UDB LUW certified V6/7/8

  11. #11
    Join Date
    Feb 2007
    Posts
    31
    Thanks for the inforamtion.But I already added the registry variable.

    :\Documents and Settings\A>db2set -all
    [g] DB2_GRP_LOOKUP=LOCAL
    [g] DB2SYSTEM=01HW050390

    and I added the domain account 'A' in the local group called DB2ADMNS...
    Regards
    Mohan

  12. #12
    Join Date
    Feb 2011
    Posts
    1
    Did you ever get resolution to this problem. I am experiencing the same thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •