Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2006
    Posts
    2

    Unanswered: Cant bring up DB after copy/clone

    Please help! I have two instances. I copied production data to test instance. To rename DB in the test instance I ran this command from the trace file:
    Completed: CREATE CONTROLFILE set DATABASE "LAWTEST" RESETLOG
    when I startup test DB I get this error:
    Total System Global Area 506431320 bytes
    Fixed Size 743256 bytes
    Variable Size 184549376 bytes
    Database Buffers 318767104 bytes
    Redo Buffers 2371584 bytes
    Database mounted.
    ORA-01589: must use RESETLOGS or NORESETLOGS option for database open

    Is there anything I can do to get DB to come up?

  2. #2
    Join Date
    Jun 2003
    Location
    West Palm Beach, FL
    Posts
    2,713

    Talking

    ORA-01589: must use RESETLOGS or NORESETLOGS option for database open
    Did you try:
    Code:
    ALTER DATABASE OPEN RESETLOGS?


    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

  3. #3
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    Becky,
    here is what we know:
    >ORA-01589: must use RESETLOGS or NORESETLOGS option for database open

    Here is what we don't know:
    Operating system name & version
    Oracle version to 4 decimal places
    EXACTLY how you cloned production to development.
    What command(s) which were issued to get as far as you got.
    Since you are not chagred by the character to post here,
    it would benefit all is you simply used CUT & PASTE to show EVERY interaction between you & Oracle.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  4. #4
    Join Date
    Feb 2006
    Posts
    2
    We're on AIX 5.2 with oracle 9.2.0.6.

    I think the source DB was not cleanly shutdown. The copy was done manually by copying the .dbf files from prod to the test area and a controlfile created and edited for the source database. here is the succesful set DB from the alert log:
    Successful mount of redo thread 1, with mount id 1449571661
    Fri Sep 7 04:32:13 2007
    Completed: CREATE CONTROLFILE set DATABASE "LAWTEST" RES
    I then tried a startup and got:

    SQL> startup;
    ORACLE instance started.

    Total System Global Area 506431320 bytes
    Fixed Size 743256 bytes
    Variable Size 184549376 bytes
    Database Buffers 318767104 bytes
    Redo Buffers 2371584 bytes
    Database mounted.
    ORA-01589: must use RESETLOGS or NORESETLOGS option for database open
    from the alert log:
    Fri Sep 7 04:33:52 2007
    ALTER DATABASE OPEN
    ORA-1589 signalled during: ALTER DATABASE OPEN...
    Fri Sep 7 04:34:09 2007

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •