Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2006
    Posts
    4

    Unanswered: Trouble starting EM on linux

    Hi,

    I've just recently installed 11g on Gentoo Linux (which I realize isn't supported, but I had 10g running fine) and am having trouble starting EM so that I can configure my DBs with my web browser. A couple of facts upfront:

    (1) I know that the DB is running because I can connect using Oracle SQL Developer from another machine using the SYSTEM account.

    (2) I'm very new to any of Oracles products so apologies in advance if I flub some of the terminology.

    When I issue the command 'emctl dbconsole start' there is quite a delay before finally Oracle spits this back at me:

    Starting Oracle Enterprise Manager 11g Database Control .................................................. ........................................... failed.
    ------------------------------------------------------------------
    Logs are generated in directory /opt/oracle/product/11.1.0.6.0/db_1/localhost_orcl/sysman/log

    So, I go to take a look at the logs and I find that there are 15 different logfiles each with different errors and I'm not sure which one indicates the root problem. My best guess is that the problem has something to do with the agent. Here is the contents emagent.log:

    2007-09-24 15:05:34 Thread-16384 Starting Agent 10.2.0.3.0 from /opt/oracle/product/11.1.0.6.0/db_1 (00701)
    2007-09-24 15:05:36 Thread-16384 [Database Instance] InstanceProperty (DBVersion) is marked OPTIONAL but is being used (00506)
    2007-09-24 15:05:36 Thread-16384 [Cluster Database] InstanceProperty (DBVersion) is marked OPTIONAL but is being used (00506)
    2007-09-24 15:05:36 Thread-16384 [Load Balancer Switch] InstanceProperty (snmpTimeout) is marked OPTIONAL but is being used (00506)
    2007-09-24 15:06:14 Thread-16384 EMAgent started successfully (00702)
    2007-09-24 12:15:33 Thread-16384 Starting Agent 10.2.0.3.0 from /opt/oracle/product/11.1.0.6.0/db_1 (00701)
    2007-09-24 12:15:33 Thread-16384 <Agent Startup> : Startup of HTTP LISTENER failure (00716)
    2007-09-24 13:12:25 Thread-16384 Starting Agent 10.2.0.3.0 from /opt/oracle/product/11.1.0.6.0/db_1 (00701)
    2007-09-24 13:12:25 Thread-16384 <Agent Startup> : Startup of HTTP LISTENER failure (00716)
    2007-09-24 13:25:12 Thread-16384 Starting Agent 10.2.0.3.0 from /opt/oracle/product/11.1.0.6.0/db_1 (00701)
    2007-09-24 13:25:12 Thread-16384 <Agent Startup> : Startup of HTTP LISTENER failure (00716)
    2007-09-24 13:41:08 Thread-16384 Starting Agent 10.2.0.3.0 from /opt/oracle/product/11.1.0.6.0/db_1 (00701)
    2007-09-24 13:41:08 Thread-16384 <Agent Startup> : Startup of HTTP LISTENER failure (00716)
    2007-09-24 13:58:58 Thread-16384 Starting Agent 10.2.0.3.0 from /opt/oracle/product/11.1.0.6.0/db_1 (00701)
    2007-09-24 13:58:58 Thread-16384 <Agent Startup> : Startup of HTTP LISTENER failure (00716)

    I'm really not sure how to proceed but if someone could point me in the right direction that would be great. Let me know if any of the information from any of the other 14 logs would be useful.

    -exits

  2. #2
    Join Date
    Jun 2003
    Location
    West Palm Beach, FL
    Posts
    2,713

    Talking


    Try finding the log which records "failed" at the end and look at the errors.

    The person who says it can't be done should not interrupt the person doing it. -- Chinese proverb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •