Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2003

    Unanswered: sp-0310 oracle10g linux

    Following Problem:

    Database is Oracle 10g + Oracle Enterprise Linux 4

    We have a big installation script. For example there is a xxx.sql
    script (receiving serveral para meters) calling the tables.sql script
    whitch contains the calls for the installation of the tables
    (definition-files in the same directory):



    We start this xxx.sql from a

    sqlplus /nolog <<!
    connect sys/$3 as sysdba
    START xxx.sql $1 $2 $3 $4 $IOPATH

    but with the following error:

    SP2-0310: unable to open file "def$rfco.sql"
    SP2-0310: unable to open file "def$indx.sql"
    SP2-0310: unable to open file "def$ixco.sql"
    SP2-0310: unable to open file "def$ixpa.sql

    When i remove the $ from the filename and in the tables.sql
    it works.

    Is it possible that i cannot use the $ - sign in a filename with linux.

    That would be bad because all of our files (definiton, packages, trigger,
    seqeuences etc) contain the $-sign.

    Any idea who to create these file WITH the $sign

    thanks for any help

  2. #2
    Join Date
    Aug 2003
    Where the Surf Meets the Turf @Del Mar, CA
    Provided Answers: 1
    The *nix shell is treating the string after the dollar-sign("$) as being a standard shell variable like $ORACLE_HOME because of the use of the HERE document "<<!"

    One possible solution is:

    which "escapes" the dollar-sign & instructs the shell to treat it as a normal character.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Mar 2003

    sp-0310 oracle10g linux - escaping with "\"

    Sorry. We already tried it with:


    Using the shell-scipt it did not work. Same error as above.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts