Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2003
    Posts
    43

    Unanswered: column name appears more than once

    Hi,

    When I am trying to execute an SP I am getting following error.

    Server 'GBR_HYD8', Procedure 't_gen_trade_list', Line 401:
    Column name appears more than once in the result column list.
    Msg 264, Level 16, State 1:
    Server 'GBR_HYD8', Procedure 't_gen_trade_list', Line 401:
    Column name appears more than once in the result column list.
    Msg 264, Level 16, State 1:
    Server 'GBR_HYD8', Procedure 't_gen_trade_list', Line 707:
    Column name addl_instr_ref appears more than once in the result column list.
    Msg 264, Level 16, State 1:
    Server 'GBR_HYD8', Procedure 't_gen_trade_list', Line 744:
    Column name addl_secp_ref appears more than once in the result column list.
    (return status = -6)


    I added two columns to the table in the already well executing SP. Obviously I looked for duplicate column names in the temp table. But there are no duplicate columns. Interestingly if you can note the first two instances (line no 401) the error does not have column names and the other two have the column names and those are not duplicate.

    When I searched in Sybase site, it says it could be due to SP and temp table names being same. Yes that is true; they are have same name. So I renamed the temp table to something other than SP name. But still I am getting the error.
    Please note no errors during compilation but only during execution
    Appreciate if somebody can help me. The Sybase version is 12.5.0.3

    Thank you

  2. #2
    Join Date
    Aug 2003
    Posts
    43
    Please ignore. This has occurred due to column mismatch of the temp table during compilation and during execution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •