Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2007
    Posts
    8

    Unanswered: Problem with extractvalue and unknown namespaces

    My problem is the following:

    I loaded a table containing an XMLTYPE-column from an external source (SQL Server 2005, via flatfile).
    This went OK.
    The XML-data in that column references several XML namespaces unknown to my Orcale database.
    The result of that is that an extractvalue(xml_data,'/tag1/tag2')
    alway returns NULL.
    In a testfile I remove the references and after that extractvalue worked.
    In production however, I will not be able to remove those references.

    Is there a way to ignore all references to XML-namespaces, or should all the namespaces and schema's be imported in the Oracle database for extractvalue to work correctly?

    Oracle version = 10.2.0.2 on Windows (not my choice but I have to live with it).

    Any help will be appreciated.

  2. #2
    Join Date
    Feb 2007
    Posts
    8
    With the help of this site: http://blog.econtentpark.com/permali...XML-in-Oracle/

    I was able to extract the values, but still I had to specify the namespaces, just as they did.
    For now it works, but the problem of possible new namespaces remains unresolved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •