Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2005

    Question Unanswered: Merge replication fails with odd message

    Hi Guys,

    I've got a merge replication set up between boxes. They're on separate sites both behind an ADSL Nat modem router. The publisher connects to the subscriber via a port forward / Nat translation at the router. This replication set up has been running for some months now. This morning I got this failure message from the merge agent on the publisher.

    "the specified remote server name may not be the network name of the remote server or the remote server is unreachable due to network problems. The step failed"

    Currently the Enterprise Mgr at the publisher can see the subscriber as can query analyzer running on the publisher.

    The host name of the subscriber is the same name used in the server registration at the publisher. The registration uses a Client Network Utility alias to resolve the name.

    If I run a ping command at the publisher using the subscribers name I get replies (the resolution of that name is done via a hosts file entry)

    Both machines are Win2k Server boxes running SQL Server 2000 Standard.

    Any ideas why the agent can't see the subscriber despite the fact its usual communications channel is working just fine?

  2. #2
    Join Date
    Jan 2005
    I've still no idea why I was getting this behaviour but I've reinitialised the subscriptions now and the problem's 'gone'.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts