Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2005
    Posts
    1

    Unanswered: How-to change database's default dbspace

    I've created a new database in Informix IDS9.30 without using the "IN <dbspace>" clause in the "CREATE DATABASE" statement. Hence, it caused all tables for this database being created into the rootdbs (the default dbspace) automatically. As the result, I have been forced to add more chunks onto rootdbs when my database growth.

    Is there any methods to reset/modify the DATABASE's default dbspace (rootdbs) to other dbspace? FYI, due to my application limitation, I can't set the dbspace in each "CREATE TABLE" statement and have to reliant on the database's default dbspace. Any idea?

    Please advise and thanks in advance.

  2. #2
    Join Date
    Mar 2004
    Location
    Netherlands
    Posts
    183
    Hi,

    The only supported action is (I think) to dbexport (better to use the -ss option) the whole database and import it again with dbimport. dbimport has an option to specify the database default dbspace. Just do dbimport -- and it will show you the syntax.

    Greetz,

    RobP

  3. #3
    Join Date
    Aug 2005
    Posts
    140
    But this doesn't solve the problem of creating additional tables with application when you have database created in rootdbs.

    In IDS 8x(XPS) there was(still is?) onconfig parameter DEFAULT_DBSPACE but I don't know about something similar in IDS. It looks like you will have to use "IN" clause in the "CREATE TABLES" statement.

  4. #4
    Join Date
    Nov 2004
    Posts
    143
    Hi,

    When you dbimport the database, use -d <dbspace_name>. This will force the new tables to be created in dbspace_name if you do not specify the dbspace name in create table syntax.

    I hope this helps.

    regards,

    Nitin

  5. #5
    Join Date
    Nov 2004
    Posts
    60

    Cool

    Remember to create the indexes in a different dbspace too!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •