Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2003
    Posts
    1,605

    Unanswered: Governor: same settings on Windows works; same settings on Linux doesn't work

    Hi,
    I would like to set-up to force all applications which last for more then 5 seconds. I wrote cfg file:
    Code:
    interval 1;
    dbname sample;
    setlimit uowtime 5 action force;
    I saved cfg file into /home/db2inst1 dir and started governor:
    db2gov start sample /home/db2inst1/rules.cfg gov.log
    The output message was:
    ===============
    db2gov deamons have been started on all nodes.
    Please check the corresponding log files for status!

    Note: The log files are stored in the /tmp/db2inst1 directory. File names are
    db2gov_start.nodenumber.
    ===============

    It is interesting /tmp/db2inst1 does not exist. I created dir and db2gov does not store data in this dir.

    It is also interesting rules files are not applied it looks like db2gov is not working. Exactly the same file on db2 for Windows works fine. On both operating systems there is DB2 v8.2 fp9.

    Any idea why db2gov is not working on Linux? Where is my log output file?
    Thanks,
    Grofaty

  2. #2
    Join Date
    Jan 2003
    Posts
    1,605
    Hi,
    I have found out what was the problem. On Windows in my case there is 'DB2 Workgroup Server Edition v8.2' and on Linux there is 'DB2 Enterprise Server Edition v8.2'.

    On DB2 Enterprise Edition (Linux in my case) if there exist /home/db2inst1/sqllib/db2nodes.cfg file and it is not empty then nodenum must be specified in 'db2gov start' command. In my case in db2nodes.cfg file there is one line info: 0 myhost_name 0
    First number is node number (0 in my case), so starting governor needs the following command:
    Code:
    db2gov start <database_name> nodenum 0 <rules_file.cfg> <logfile.log>
    Stopping governor:
    Code:
    db2gov stop <database_name> nodenum 0
    Logs on Linux are written to sqllib\log directory and on Windows there is sqllib\db2\log directory. Don't understand why IBM is not using the same directory structure! Because nodenum is specified on 'db2gov start' log file gets '.0' at the end of file name so log file name in my case is 'logfile.log.0'.

    BTW, on forums I have found DFT_MON_UOW dbm cfg parameter should be set to on to use 'uowtime' command in cfg file, but in my case this was not needed - it just works with this parameter off. Just pointing if someone will need this parameter.
    On Linux check parameter setting: db2 get dbm cfg | grep DFT_MON_UOW
    On Windows check parameter setting: db2 get dbm cfg | find DFT_MON_UOW
    On Linux/Windows set parameter: db2 update dbm cfg using DFT_MON_UOW on

    Hope this helps to anyone out there,
    Grofaty
    Last edited by grofaty; 10-30-07 at 06:38.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •