Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2006
    Posts
    43

    Unanswered: docmd.transfertext problem

    > Hi,
    >
    > I am using access 97 and tried to import a csv file to the mdb table. I
    > run a code as following:
    >
    >
    > DoCmd.TransferText acImportDelim, "Specification4", "input",
    > DEFAULT_PATH & "online.txt", 1
    >
    >
    > In online.txt, there is a field which is 10 digit number and I specified
    > it as a double datatype in the specification4. After the import, I found
    > out that the 10 digit number data in the field get empty in the destined
    > table while other fields are all right. Therefore I import manually using
    > specification4 instead of running code. This time the 10 digit number data
    > get imported to the destined table. Can anyone please help me on how to
    > fix the problem so that I run the code? Thanks.

  2. #2
    Join Date
    Nov 2003
    Posts
    1,487
    Ugh...the way I see it...forget about the Specification4 stuff. Make yourself a Schema.ini file and place that there instead. You can setup whatever structure you like that way. You just need to make sure the Schema.ini file (which is a simple text file) is located where your csv text files are located.

    See Access help regarding the Schema.ini file and the TransferText method.

    (just my opinion though)
    .
    Environment:
    Self Taught In ALL Environments.....And It Shows!


  3. #3
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    If you're re-posting your question (from another forum perhaps) it would be a good idea to link it
    George
    Home | Blog

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •