Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2007
    Posts
    4

    Unanswered: increasing upload_max_filesize

    hi,

    I am trying to increase the upload_max_filesize in the remote linux server with the help of .htaccess file.It worked and I increased it to 4M but while I tried to upload a file of 3.2MB the page expired.

    I have increased the max_execution_time to 300 seconds but still not getting the problem solved.

    Can anybody provide me some good solution???

  2. #2
    Join Date
    Mar 2007
    Location
    636f6d7075746572
    Posts
    770
    Have you specified the upload size in the html form as well? The is specified in bytes i think, so the below sets to 100Kb

    Code:
    <input type="hidden" name="MAX_FILE_SIZE" value="100000" />
    Also if you run phpinfo(); do you see the maximum upload file size specified in the configuration?

  3. #3
    Join Date
    Sep 2007
    Posts
    4

    Yeah it is there

    Thanks!!

    The changes are already being reflected in the configuration setting i.e the phpinfo() ,but page expires after 2-3 minutes.Is there anything in the linux server's setting that is causing the problem??

  4. #4
    Join Date
    Mar 2007
    Location
    636f6d7075746572
    Posts
    770
    Could be a timeout issue with either PHP or Apache.
    I believe both have settings, and it sounds like you've set the PHP one to 5 minutes (max_execution_time 300).
    Try using the function set_time_limit(int seconds) in your PHP as well and see if that'll extend it. 5 minutes is a long time to wait for a file upload though...
    Check your apache for the following : LimitRequestBody <value>
    This will restrict uploaded content to a certain size from a single connection request.
    Also check the TimeOut directive in Apache. You may find it limited to 60 seconds or slightly more (not enough). Make this large for larger file uploads.

    Are you trying to upload multiple files at once or just the one?
    Have you had success with smaller files?
    Is there a restriction on the filesize for tmp files? i.e. are you reaching a space quota?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •