Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2007
    Posts
    45

    Unanswered: Printing subreport with a parameter

    Okay, I thought I solved this in an earlier thread, but I didn't. I have a unbound main report with two subreports. One of the subreports is built on a parameter query. The problem, it not only prompts for the date when you open report (which is suppose to happen and is fine), but it prompts you again for the date when you go to print it. Why? How do I debug this.

    My access database is attached.
    Attached Files Attached Files

  2. #2
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926

    Example

    jill,

    Here's your mdb with a report form added and some other features. I've included several different examples you can utilize. Just substitute the tables with the tables you want to query off of.

    If this doesn't work for you or seems overly complex, let me know and I'll try to simplify it.

    Nice looking reports you've designed. I hope this helps.
    Attached Files Attached Files
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

  3. #3
    Join Date
    Dec 2004
    Location
    Madison, WI
    Posts
    3,926

    Example 2

    In this example, I made it so the queries in your report are based on the StartDate and EndDate on the Reportform.

    Again, I hope this works for you. You can delete the sample tblCustomers and other report buttons.
    Attached Files Attached Files
    Expert Database Programming
    MSAccess since 1.0, SQL Server since 6.5, Visual Basic (5.0, 6.0)

  4. #4
    Join Date
    Apr 2007
    Posts
    45

    Thanks that worked

    Thanks PK for the idea of adding the parameters to a form. It works and it prints without prompting for the date again.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •