Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2006
    Posts
    14

    Unanswered: Report Class Umbiguous in crystal reports

    Hello,

    Can someone please help me. I've spent so much time on this one,i'm now

    i've recently upgraded my web application from VS 2003 to VS2005,I've worked through other errors but this one i can't figure it out. here is the error:

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'stdole, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 12: <add assembly="Microsoft.VisualBasic, Version=8.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Line 13: <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    Line 14: <add assembly="stdole, Version=7.0.3300.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Line 15: <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Line 16: <add assembly="CustomMarshalers, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    Source File: c:\inetpub\wwwroot\pmwebapp\web.config Line: 14

    Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

    Does anyone know what i'm missing.

  2. #2
    Join Date
    Feb 2007
    Posts
    348
    It doesn't look like a Crystal error that I know of. You get this when you open Crystal or some other time? Is there an error number associated?

    I ran a couple of your messages through google and I got the implication that it was a .net issue more than a crystal issue.

  3. #3
    Join Date
    Oct 2006
    Posts
    14

    Reports Class Umbiguous in crystal reports

    Silly me, You're right that error is not on crystall reports, had to change some things on my config file after the upgrade,i managed to sort it out though. The error i should've posted is the one below:

    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: BC30560: 'ReportClass' is ambiguous in the namespace 'CrystalDecisions.CrystalReports.Engine'.

  4. #4
    Join Date
    Feb 2007
    Posts
    348
    I found this at some other forums:

    I recently spoke with a technical support representative at Crystal Decisions. Reloading references and the crystalreportviewer seemed to work (Check for duplicate versions in the Configuration Element in the Web.Config). The parameters are loading correctly but the data is not loading for the report. These are untyped reports so they are not included in the project. We are working on resolving this issue and I will make another post when this is fixed.

    So when converting from 2002 to 2003 reload your references and toolbox controls.
    A couple other sites are saying to make sure you have the latest service packs installed.

    You said you went through an upgrade. What did you upgrade?

  5. #5
    Join Date
    Oct 2006
    Posts
    14
    Thanks so much for the response...

    I upgraded from VS 2003 to VS 2005. My web application works fine on my local machine , problem comes when I put it on the server, I get that one error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •