Hello,
From the 'Object View' in Control Center, I right click on the database in the left panel and select 'Query'. The 'Enter Credentials' box appears, and I type in my User ID and Password. The password contains an exclamation mark. When I attempt to connect with my credentials, I get the following error message:

------------------------------ Commands Entered ------------------------------
connect to (server) user (user Id) using ********;
------------------------------------------------------------------------------
connect to (server) user (user ID) using !2Dw
SQL0104N An unexpected token "!" was found following "<identifier>".
Expected tokens may include: "NEW". SQLSTATE=42601

SQL0104N An unexpected token "!" was found following "<identifier>". Expected tokens may include: "NEW".

Explanation:

A syntax error in the SQL statement was detected at the specified
token following the text "<text>". The "<text>" field indicates
the 20 characters of the SQL statement that preceded the token
that is not valid.

As an aid to the programmer, a partial list of valid tokens is
provided in the SQLERRM field of the SQLCA as "<token-list>".
This list assumes the statement is correct to that point.

The statement cannot be processed.

User Response:

Examine and correct the statement in the area of the specified
token.

sqlcode : -104

sqlstate : 42601
****************************************
I've tried to input the password in single and double quotes. How do I correctly express the password?

Thank you for your help!

cdun2