Results 1 to 11 of 11

Thread: DB2 Parameters

  1. #1
    Join Date
    Oct 2006
    Posts
    12

    Question Unanswered: DB2 Parameters

    Hello everybody...

    We are using a cluster with 2 nodes.
    Node 1 is an application server,
    Node 2 is the db server (db2).

    It seems when I start the application, the application establishes a connection to the application server and the application server connects to the database.

    Now we have more and more employees who use this application.
    Since longer time we noticed the problem that only 60 users can work with the application at the same time.

    Today I wanted to add some users to the database with the application. As I noticed that already 60 users are connected, I wanted to do it manually on the db servers command line. But as I wanted to connect to the db with "db2 connect to xxx" I got the error message "SQL1040N The maximum number of applications is already connected to the database. SQLSTATE=57030".

    As I checked the database configuration I saw that there is a parameter called MAXAPPLS which is set to 60.
    Can anyone tell me how I can increase the value of this parameter and if anything else is to do to increase the maximum concurrent connections to the database???

    Thanks in advance for any help

    Best regards
    Raphael

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    What is your DB2 version and OS?

    Issue: "db2 get dbm cfg" as instance owner
    What are values for:
    max_connections
    max_coordagents

    Andy

  3. #3
    Join Date
    Oct 2006
    Posts
    12
    Hello Andy

    Thanks for the very quick answer :-)

    OS: AIX 4.3
    DB2: 0x0800 (I'm not sure, this is the "Database manager configuration release level"-Value)
    max_coordagents: MAXAGENTS -> 100
    max_connections: I can't find any parameter like this
    Attached Files Attached Files

  4. #4
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Run db2level as instance owner to get DB2 version.

  5. #5
    Join Date
    Oct 2006
    Posts
    12
    db2level gets me this....

    DB21085I Instance "dbadmin" uses DB2 code release "SQL05020" with level
    identifier "02070103" and informational tokens "DB2 v5.2.0.30", "c990717" and
    "U465112".

  6. #6
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Quote Originally Posted by cineFreak
    db2level gets me this....

    DB21085I Instance "dbadmin" uses DB2 code release "SQL05020" with level
    identifier "02070103" and informational tokens "DB2 v5.2.0.30", "c990717" and
    "U465112".
    Well that explains why max_connections is not listed as a parameter. V5.2 is very old. Current supported versions are 8.2, 9.1, and 9.5.

    You can set max_agents to the same value as maxappls. This should fix your problem.

    Also seriously consider upgrading to one of the supported versions.

    Andy

  7. #7
    Join Date
    Oct 2006
    Posts
    12
    Well... the problem is that the whole system is really old and we don't want to invest much more money in this system because we want to replace this system by another one.
    The new system will be ready not before the next 2 years. So we try to make the best with the existing one ;-)

    Please can you tell me the command to change these parameter values?

    Thanks for your help :-)))

  8. #8
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    UPDATE DB CFG FOR MyDB USING MAXAPPLS 200
    UPDATE DBM CFG USING MAX_AGENTS 200

    Andy

  9. #9
    Join Date
    Oct 2006
    Posts
    12
    Okay, I will try this...

    I think I also have to restart something after this changes... Is it enough to use DB2STOP/DB2START or do I have to use also RESTART DATABASE??

  10. #10
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    You will have to db2stop/db2start. If you have to "DEACTIVATE DATABASE" to shut it down, then you will need to "ACTIVATE DATABASE" as a last step.

    Andy

  11. #11
    Join Date
    Oct 2006
    Posts
    12
    Okidoki... thank you very much for you help! :-)))

    Best regards
    Raphael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •