Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2007
    Location
    Prijedor, BIH
    Posts
    2

    Unanswered: Driver's SQLSetConnectAttr failed ASP to INFORMIX

    Dear Frineds....

    I have tried to find an answer on the forum but it seems noone is working with informix DB servers.

    This is my issue.

    I work in a large co-orporation and we have few types of databases running on several platforms.

    I am trying to make a IIS (integrated information system) with all of them using an .ASP application.

    I have successfully created connection strings to mySQL on two machines and msSQL on a third.

    When i try to make a connection sting to INFORMIX server i get the following error.

    Microsoft OLE DB Provider for ODBC Drivers error '80004005'
    [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed
    /proba/index.asp, line 3


    Line 3 is the following code

    Conn.Open "Dsn=dsnljubija;driver={INFORMIX 3.31 32 Bit};Host=ljubija;Server=ds_ljubija;Service=turbo; Protocol=olsoctcp;Database=ljubija07;UID=informix; PWD=informix"

    I have created an DSN in System DSN.
    I am trying to run this .ASP application on Windows Server 2003 R2.
    The informix server on another machine in the LAN.

    ALSO PLEASE NOTE

    I have used the same application on a local machine in the same network on Windows XP pro connecting the the same Informix server as what I am trying on the server and it connects with NO problem, it ran fine.

    Thank you in advance

  2. #2
    Join Date
    Jul 2003
    Location
    Amsterdam, Nederland
    Posts
    450

    See here

    I think your problem is discust in here
    see bottom for solution, but to read the whole thing can be verry inlighting too

    http://www.tek-tips.com/viewthread.cfm?qid=22412

  3. #3
    Join Date
    Dec 2007
    Location
    Prijedor, BIH
    Posts
    2
    No no luck with that link.

    Anyone else have a clue why this would work on a local machine in a netwrok and not on the file server with exactly the same settings and connection string.

    Thanks in advance..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •