Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2007
    Posts
    2

    Exclamation Unanswered: Still can't see MySQL from Apache2/PHP.

    As per a previous post from savbill on an XP box...

    I have ensured php5apache.dll is active on the Apache Server... PHP works fine, there... Until I try to access MySQL.

    I have copied the libmysql.dll to the system32 directory, as per the post.
    I have not copied it to the Apache2 folder.

    Now... For whatever reason, my install of PHP-5 *did not* include an 'ext' folder (php-5/ext/). I had to create it myself. I have also copied all extensions from PHP-4's 'extension' folder to the 'php-5/ext' folder that I had to create.

    I have ensured that, in php.ini, the 'extension_dir=' points to the extension directory I had to setup under PHP5.

    I have also ensured that the 'extension=php_mysql.dll' *is in* php.ini, as well as ensuring the php_mysql.dll resides in the 'php-5/ext' folder. (by the way, I have also ensured these two lines in php.ini are not commented out).

    WHENEVER I try to hit MySQL from the Browser/PHP, all I get is a blank screen (PHP/Apache *without* hitting MySQL works fine). This happens with my test code (that used to work fine w/ PHP-4) as well as phpMyAdmin. When I view the source code for the page returned to me, all I get is:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
    <BODY></BODY></HTML>

    Any ideas ???

    Greg Pace

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    I don't know if it still applies, but when installed MySQL & PHP on XP the MySQL libraries were banjaxed, you needed to do another step after downloading, I think it required getting a more recent version of the MySQL library.

    Id check the documentation for the version you are using,
    Id check the documentation for the PHP release
    Id check the web to see if there are similar or related problem for the versions (of both PHP & MySQL) you are using.

  3. #3
    Join Date
    Dec 2007
    Posts
    2
    Thank you for your reply.

    You are correct. PHP-5 did not include some necessary DLLs:
    libmysql.dll
    php_mysql.dll
    php_mysqli.dll (the 'improved' version of php_mysql.dll)

    After some Google time and some tweaking, I finally started getting an error return from phpMyAdmin:

    -----
    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.
    -----

    A review of Apache's error log indicates that I need to ensure the current setting for session.save_path is correct.

    Where is that variable ??

    G.Pace

  4. #4
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    as session.save_path is a php setting I'd expect it to be int he PHP.INI file. Googling session.save_path suggests it could also be something banjaxed with your base directories

    one thing to bear in mind is that PHP grew up in the *nix world so directories must be specified in the *nix way
    ie c:/path/to/my/php.ini
    instead of
    ie c:\path\to\my\php.ini

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •