Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2003
    Location
    Hertfordshire, England
    Posts
    78

    Unanswered: AllowEdits not working

    My form properties are set so that allowedits=false so when the form opens you should not be able to edit any of the fields. This was the case until I had to change my form because of some other bug.

    I re setup my form to be the same but now when it opens you can edit the record even though it is set to not allow edits. I do find that if you move to the second record and then back it locks so you can't edit.

    Any ideas? Is that some kind of bug?

  2. #2
    Join Date
    Aug 2003
    Location
    Cleveland USA
    Posts
    184
    Do you have code anywhere in the form that sets AllowEdits? Or maybe Enabled or Locked?

  3. #3
    Join Date
    Nov 2007
    Location
    Adelaide, South Australia
    Posts
    4,049
    I've never encountered such a bug. As Lisa said, look for code that is turning AllowEdits on.
    Owner and Manager of
    CypherBYTE, Microsoft Access Development Specialists.
    Microsoft Access MCP.
    And all around nice guy!


    "Heck it's something understood by accountants ... so it can't be 'that' difficult..." -- Healdem
    "...teach a man to code and he'll be frustrated for life! " -- georgev

  4. #4
    Join Date
    Sep 2003
    Location
    Hertfordshire, England
    Posts
    78
    Actually still not working.

  5. #5
    Join Date
    Jan 2007
    Location
    UK
    Posts
    11,434
    Provided Answers: 10
    bound or unbound forms?
    Have you considered setting the locked property of the relevant controls to True?
    George
    Home | Blog

  6. #6
    Join Date
    Sep 2003
    Location
    Hertfordshire, England
    Posts
    78
    It is a bound form. I will have a play with the locked option.

  7. #7
    Join Date
    Sep 2003
    Location
    Hertfordshire, England
    Posts
    78
    I can get around this problem by using the locked property so will leave it there.

    thanks.

  8. #8
    Join Date
    May 2009
    Posts
    1

    Allow Edits fix

    I just ran into the same problem - found that after setting me.AllowEdits = False, you need to do a me.refresh to get it to work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •