Hi Gurus,

It's been a while since my last post here, have been quite busy for the past few months. Anyway, I got a question here regarding transportable tablespace

I have an upcoming project which will be a migration from Oracle 8i running on ? platform to Oracle 10g running on RHEL 4 (reason why the first platform is "?" is because our manager haven't got hold the specs) Since I want to prepare myself for this project, I initiated a mock migration. Here listed below are the softwares I used:

I have a notebook with dual boot capability so...
I. Source Database
Oracle running on Windows Vista
II. Destination Database
Oracle running on Oracle Enterprise Linux

My first idea was to use exp/imp method, so while on vista, I tried exporting tablespace "rman_tbs" (just for the purpose of trying) from Oracle by executing
exp '/ as sysdba' file=rman_tbs.dmp transport_tablespace=y statistics=none tablespaces=rman_tbs

* tablespace rman_tbs have 2048 blocksize

Next, I copied rman_tbs.dmp and its datafile, rmantbs01.dbf into a media, shutdown the instance, perform a machine restart, booted in Linux, started instance and performed the following:

* current configuration supports 2k cache

DATAFILE '...../rmantbs01.dbf' SIZE 500M

after creating the tablespace, I gave quota unlimited on RMAN_TBS to my user (e.g. archmage).

now, I tried the imp

imp user/password tablespaces=RMAN_TBS transport_tablespaces=y file=rman_tbs.dmp datafiles='rmantbs01.dbf'

it gave me this error

************************************************** ******
Connected to:
Oracle Database 10g Enterprise Edition Release - Production
With the Partitioning, OLAP and Data Mining options

Export file created by EXPORT:V10.02.01 via conventional path
About to import transportable tablespace(s) metadata...

Warning: the objects were exported by SYS, not by you

import done in US7ASCII character set and AL16UTF16 NCHAR character set

export client uses WE8MSWIN1252 character set (possible charset conversion)

IMP-00003: ORACLE error 6550 encountered
ORA-06550: line 1, column 7:

PLS-00201: identifier 'DBMS_PLUGTS.NEWTABLESPACE' must be declared

ORA-06550: line 1, column 7:
PL/SQL: Statement ignored

IMP-00000: Import terminated unsuccessfully

************************************************** ******

to cut the story short, I ended up with metalink Note:77523.1, observed certain restrictions and now the error was something can't import because datafile is of different version

this gets very exciting