Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2008
    Dublin Ireland

    Unanswered: Security Problem

    Hi All,

    Please could you help me. I added a new user and deleted two users on Friday using the security wizard then modified a DB. When I tried to open one of my DB this morning I was not prompted to enter user name and password as normal just DB password then an error message came up that 'I did not have the necessary permissions to use the DB and have the administrator or person who created this object set the necessary permissions for you'. I am the administrator for all my DBs (I have 5 in total). The DB are stored on a network and IT restored my DBs from previous night and this still has not worked is there any way of fixing this I have ten years worth of data in some of these DBs.

    Many thanks in advance

  2. #2
    Join Date
    Nov 2004
    out on a limb
    Provided Answers: 59
    try to restore the workgroup file .mdw, that contains all the permissions
    you shouldn't need to restore the data, just the permissions, you may need to re-associate the permisssions files with the individual users

    Ive always tended to change the password of old users just in case they have created an object which I need access to at a later date.


  3. #3
    Join Date
    Nov 2007
    Adelaide, South Australia
    Me too... I NEVER delete users from an MDW.

    And I pray you have a good backup of that MDW file.
    Owner and Manager of
    CypherBYTE, Microsoft Access Development Specialists.
    Microsoft Access MCP.
    And all around nice guy!

    "Heck it's something understood by accountants ... so it can't be 'that' difficult..." -- Healdem
    "...teach a man to code and he'll be frustrated for life! " -- georgev

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts